9

Every day I come into the office and plug my mac into my Thunderbolt display. It says the name "yourcomputer" is in use and renames it "yourcomputer-2" (or -3 or -4 ...). How do I make it stop?

  • Do you have the Mac hooked up to Ethernet through the Thunderbolt display? – CajunLuke Jun 28 '12 at 17:48
  • Yes, it's ethernet through thunderbolt. – chrismealy Jun 28 '12 at 21:18
  • is the name "yourcomputer" unique on your work's network? i.e. are there other people with Mac's that might have the same computer name or are you also connecting via a second network such as wi-fi? – Stu Wilson Jul 7 '12 at 20:54
  • another possibility, do you plug into the same display every day or do you hot desk between multiple available Thunderbolt displays? – Stu Wilson Jul 7 '12 at 21:15
  • nope, one laptop, one display, one unique name on the network – chrismealy Jul 9 '12 at 23:34
1

Try making your hostname permanent by typing this command into the Terminal:

sudo scutil --set HostName yourcomputer

My hostname kept changing when I connected to the network because the router was broadcasting a different hostname, and this fixed it.

  • In my case is "ComputerName" that keeps changing. This does nothing more than setting it from system preferences. A few seconds later it will return to "computername (n)". This is the log of what happens exactly after it changes. – Rnhmjoj Sep 30 '14 at 14:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .