So, I had a MacBook Pro 15", Late 2011, that I've been using daily since I got it last October. I set up time machine and every day after work, I would bring my laptop home and plug it into my time machine disk and let it do it's thing. I even used my backups from time to time, when I deleted some bit of code on accident (or on purpose) and decided I wanted to use it after all.

Last week I sold my trusty old MacBook and bought a new MacBook Retina. The guy I was selling it to wanted to keep some of the apps I had installed and he didn't want a full wipe/restore, so I did what I have done before when I sell a Mac: create a new user account and delete the old one, effectively wiping all of my user data.

However, I created the new user and deleted the old one (and ALL of my data) with my time machine hooked up and running.

Now, in restoring my time machine backup to my new laptop, all of my user data is gone. I see my user in the Users list in the Migration Assistant, but under my user name it says "This users's data doesn't need to be transferred."

I tried selecting everything that's available and restoring, but all of my data is gone.

Looking through my backup files, I see the backup for this laptop with all of the different dates. I can expand any of the dates and navigate down into Users, but my user account is gone from every single backup on every date.

Is this an expected behavior? Has anyone ever seen anything like this?

One other thing of note : I had FileVault turned on on the old MacBook, encrypting my home directory. Is there some magic combination of things I need to do in order to restore from an encrypted home directory?

The strange thing is, the restore re-created my user and it remembers my password. But everything, everything about the account has been lost. Keychain, mail settings, all files and libraries, preferences... The only thing it seems to have kept is my login photo, username, and password.

  • Since you just bought a Mac - you might call Apple or visit the genius bar to get support on this. Based on your comments to my answer it appears there is a deeper issue and you might get professional help to make sure you can't retrieve the data. I'm hoping it's a permission issue where you don't see the data, but this is clearly a case of things are not working as expected.
    – bmike
    Commented Jun 28, 2012 at 16:11
  • Sorry you're having trouble. If I can make a suggestion for the future, don't depend 100% on Time Machine. Use SuperDuper or Carbon Copy Cloner to make a complete backup every day or every week.
    – Ex2bot
    Commented Apr 5, 2015 at 18:59
  • I still got the same response while migrating from an old MacBook with 2 users to a new one. When using Migration Assistant to copy the backup via Time Machine I got the same message for the second user. Using Time Machine to retreive a copy on the old Mac when logged in as this second user still works. So the data must still be there.
    – Pisca46
    Commented Oct 26, 2020 at 14:34

2 Answers 2


Just restore from a snapshot that is a bit older than when you did the wiping. If for some reason this isn't easy, you can also delete the folders by time in your backup.

If you have any doubts, you could use a tool like BackupLoupe to make sure you prune only the "bad" backup events and data.

  • In looking through the snapshots, none of them have the user that was deleted. It's like time machine decided that, since I deleted that user, it should delete all of that user's data from the beginning of time.
    – AWT
    Commented Jun 28, 2012 at 16:02
  • Odd - that's not how it works. Time machine doesn't delete a file until every last instance of the file in every snapshot is deleted. It's more likely you had excluded the home folder since the only way to delete a backup is to enter Time Machine and ask that all backups of a folder be cleaned and deleted. That has multiple warnings and also takes a long time if you have several months of snapshots to clean up one by one. Even if you ran out of space on the backup drive, TM deletes entire snapshots to free space and not parts of a snapshot.
    – bmike
    Commented Jun 28, 2012 at 16:09
  • That's why I don't really understand what happened. I definitely didn't exclude my home drive, and had successfully restored individual files from my home folder in the past. But during the migration, that user now has the “This user's data doesn't need to be transferred” message which I've never seen before, and none of my data is there.
    – AWT
    Commented Jun 28, 2012 at 16:13
  • That error message isn't well documented anywhere on the public internet. Best to go to Apple until someone documents what that really means. Sorry I can't be of more help on this...
    – bmike
    Commented Jun 28, 2012 at 16:47

Time Machine cannot back up a FileVault I user while the user is logged in. Normally it will offer to back up the user when you log out, but if you never log out, or always decline the offer when you do, your user account never gets backed up.

If TM did back up your user, it did it while the user was logged out. In that case, what it backed up was essentially an unmounted sparse bundle disk image. If you log in as a different admin user, you should be able to restore the entire home folder. I don't have a FileVault I user available to test with, but I remember doing this, just as a test, and it worked. I may have had to restore the home folder under a different name, and then use my admin's sudo powers to give it the correct ownership and name before the FV-using user could use it.

The important thing is that when browsing through the backup, do no not attempt to descend into the FV user's home folder. It has to be restored in its entirety or not at all, and cannot be restored in-place.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .