I bought an oldish MacBook 13" Unibody (late 2008) and when I got it one of the first things I did was to install Mac OS X Lion.

Everything was working fine, until I applied an update that made the trackpad stop working (it only accepts clicks, no touch is recognized).

This is the "Trackpad Firmware Update" from the automatic updates.

When starting this firmware update a window appears with a status message, Cancel and Update buttons. After clicking the Update button, it starts installing, appears to complete, status changes to Finishing..., and Update button comes back active at some point.

After that I have tried (unsuccessfully):

I'd be thankful for any ideas to try out.

  • I tried applying this patch with Mac OS X Snow Leopard, with little success. Behavior is similar to installing in Lion...
    – acseven
    Commented Jul 22, 2012 at 16:43
  • No one has any ideas on things to try...?
    – acseven
    Commented Sep 7, 2012 at 8:41

1 Answer 1


Ended up taking it to an apple technician and they fixed it...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .