7

I have a Macbook Air running 10.7.4 and I'm trying to connect to ethernet using the official Apple USB to ethernet adapter. However, the mac never detects the new network interface. It never displays a dialog asking me to set it up. It doesn't show up in network preferences. As far as I can tell, the mac doesn't know it's even plugged in.

I've verified both the adapter and the ethernet cable I'm using work with another mac. I've tried both USB ports on the Air.

Anyone have an idea how I can troubleshoot this? Is there a USB utility that I could check out?

  • 1
    I assume you already did a reboot of the MBA? – nohillside Jun 26 '12 at 17:50
  • Yep, rebooting doesn't help. – Jason Jun 27 '12 at 0:19
3

I had the same problem and a couple of minutes ago I saw something about the "Android File Transfer Agent" having problems with the device. So uninstalled "iSyncr" software (sync android over Wifi), disconnected the usb device, plugged it again and now it's working fine.

https://discussions.apple.com/thread/3941878?start=0&tstart=0

1

Yes - you should see the hardware device in Lion's System Information pane under USB devices if it has any working pins that the computer can see and sense.

From there, it's an OS / driver / kernel issue and the simplest thing to do is often to install a clean OS on an external drive and see if it's somehow a setting or corrupt preference file.

These have been out for so long, it's very unlikely the OS doesn't have the correct driver, so it's more a glitchy or buggy situation as opposed to the very new Thunderbolt to Gigabit Ethernet where most Macs that shipped before this last batch need a thunderbolt firmware update to make the OS see the adapter.

  • I see the adapter under System Information, and I can see it in USB Profiler. Is there alternative to installing the OS on a separate drive? Maybe a driver I can reinstall or something? – Jason Jun 27 '12 at 0:22
1

I have INSIGNIA USB to Ethernet not detected. I installed driver from here: http://www.nikvdp.com/technotes/getting-non-apple-ax88772-usb-ethernet-to-work-on-mavericks/ and it works now.

1

I've resolved by simply create a new location in Network Preferences and then try connecting it again by clicking "Apply" on this new location.

0

On my 2017 15" MacBook Pro a simple reboot solved the issue. Always try this first, before trying a crazy solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .