Here's my setup. I purchased a HD movie (my first ever!) from the iTunes Store onto my Mac mini. iTunes on this Mac mini is configured for Home Sharing. Now, when I launch the Videos app on the new iPad, it lists my Shared Library correctly together with the movie that I just downloaded. However, when I tap the Play button, the screen goes blank for a moment before displaying a "Cannot Open" error message.

I am bedazzled by the fact that I can't play this very same movie on my HDTV which is connected to the Mac mini via Mini DisplayPort to HDMI cable (HDCP error, but that's another story for another question), I'm now totally flabbergasted that I can't even play this movie via a channel that Apple has been shouting about.

I tried playing the movie on my MacBook Pro and it works correctly, therefore the file is not corrupted. I am also sure I can sync the entire movie (all 7GB of it) into my new iPad, and watch it from there, but why?

  • Do you have any other issues using the iTunes Store, or App Store, from your iPad? Errors when trying to update apps or buy media content maybe?
    – kopischke
    Jul 21 '12 at 22:30
  • Nope, haven't been having any other issues aside to this.
    – XCool
    Jul 23 '12 at 1:42
  • I asked because it sounds like your account credentials check fails; the setup by itself should work (and does so for me). Have you tried removing both iTunes and the iPad from Home Sharing, then reenabling it first in iTunes, then on the device? Also, you could try reviewing your iTunes account credentials in iTunes (you’ll find them in the Store section) – edit them and see if they validate when submitting. Beyond that, I’m stumped.
    – kopischke
    Jul 23 '12 at 9:47

You must log in to answer this question.

Browse other questions tagged .