10

Is it possible to speed up the transition between spaces? I often open my applications in full screen mode but I would like the transition to be a bit faster, is there a way to speed this up (i.e. when I hit Ctr rightarrow it moves one space to the other quicker than the default setting).

  • 1
    A quick search found this. However, it uses SIMBL, so I have not tried it. – gentmatt Jun 25 '12 at 18:20
  • I think I will hold off for a bit as SIMBL seems a bit obscure and I would prefer not to install it but exactly what I am looking for. Thanks for the suggestion! – rudolph9 Jun 25 '12 at 18:29
  • There's a duplicate at Super User, but it doesn't answer the question though. – Lri Jun 25 '12 at 21:32
1

What you are looking for is TotalSpaces.

The new version has the ability to remove the delay completely. Working great so far.

  • 1
    I appreciate the response, but I'm really looking for something I can execute on the command line rather than an app I would need to purchase, I'd like to be able to include it in my dotfiles – rudolph9 Nov 19 '12 at 1:50
  • 1
    I hear ya! Your need is very similar to mine, and that would be first prize. After looking for a while, I couldn't find a command line option. :( Unfortunately it doesn't look like there is a OS X Defaults setting for this, and TotalSpaces may use a hotpatching type of approach similar to SIMBL. – cavalcade Nov 20 '12 at 3:02
  • TotalSpaces does infact remove the transition, but breaks CMD-Tab application switching. – Gav Feb 5 '13 at 12:25
  • @Gav: I'm using 'TotalSpaces 2' 2.1.20, on Mavericks, and, maybe it's because I use a third-party Cmd+Tab replacement called '[manytricks.com/witch/](Witch)', but it works beautifully with Witch'd Cmd+Tab'ing. Lightning fast, no spaces switching animation, it's a dream! – user46942 May 11 '14 at 9:53
0

I'm not sure if this works, as I have not tested it out myself, but I found this terminal command here:

Disable the switching Spaces animation in the terminal by typing: defaults write com.apple.dock workspaces-swoosh-animation-off -bool YES && killall Dock

To enable again, type the following: defaults delete com.apple.dock workspaces-swoosh-animation-off && killall Dock

This completely disables the animation, and I'm not sure if that's what you want, but I imagine that if the animation is completely disabled, the switch between spaces would be instantaeneous.

Hope this helps!

  • 6
    That stopped working on 10.7. – Lri Jul 2 '12 at 4:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .