I would like to know if anyone has an idea or suggestion to what's happening on my SSD.

I was using Lion on my Vertex 3 SSD 240GB - MacBook Pro (early 2011 model) and everything was running well until this week, when the system got stuck at Apple screen logo with that "loading" icon.

I tried to boot in the verbose mode and after 30 minutes the fsck process started but no output in following 40 minutes. Also tried Internet Recovery (the process got stuck while trying to download Lion) and Snow Leopard Install DVD (also got stuck while trying to install), but now luck.

My last try was to use another hard drive running Lion, connect my SSD via USB adapter, open Disk Utility, create a new partition, open Snow Leopard Installer (from its DVD) and make a new installation having the SSD as target. The installation was ok and after rebooting the OS, I was able to boot my SSD connected via USB. Tried to move it back to the internal SATA connector and the issue remained the same.

So here is what I have:

  1. Hard Drive with Lion installed - works from the internal SATA connector.

  2. SSD with Lion installed - only works (boot) from USB adapter. From its SATA, it shows the Apple screen logo and loading icon.

Has anyone faced this issue?

Thanks in advance, this is my first question here. Let me know if any other info is required because I'm kind of new to Mac OS X.

  • Well, did you change anything in your setup before the initial incident? As for Snow Leopard: Are any special device drivers required for your SSD (probably not, but just to be sure)? Do you have any computer or drive enclosing nearby with a SATA connector (to verify whether the problem lies more with the SSD or the computer)? – nohillside Jun 24 '12 at 15:51
  • Thanks for your reply @patrix. I haven't done any changes before the initial setup. Regarding Snow Leopard, this was the first OS installed on this SSD (then upgraded to Lion). I'm going to test it on another MacBook Pro next week and report here how it goes. By this, I may see if it's working (booting the system) on another SATA connector. Besides the SATA connector, is there anything different and relevant between launching the system from MBP's SATA connector or USB? Thanks! – D.D. Jun 27 '12 at 3:06
  • D.d. Did you Find a solution i am having the same problem. Yosemite on ssd boots from USB but not internal. I am almost sure the sata connection works as my Old hdd with yosemite worked but slow – alex Aug 11 '15 at 11:32

You must log in to answer this question.

Browse other questions tagged .