I've got 2 applications that I installed via the Mac App Store that are still in the "waiting" mode. How do I get these applications to finish installing? Or how do I remove them and try again?

By "waiting" mode I mean they are showing a download progress bar and have the word "waiting" overlaid their icons inside of the launchpad app. (I would take a picture but it doesn't seem to let me while showing the launchpad)

  • Try the iTunes sync.
    – user479
    Jun 21 '12 at 21:45
  • iTunes says "All purchases have been downloaded for this account". The icons are still in the "waiting" mode in Launchpad. And I still cannot use them. (Ibooks Author & ClamXAv) BTW, this was the first time I launched iTunes on this computer. I normally use my desktop for syncing the iPhone. It didn't even have my Apple ID in it. I had to put it in for the first time.
    – Jason
    Jun 21 '12 at 22:15
  • I just had this problem with the Yosemite beta. Rebooting seems to have restored functionality. Aug 24 '14 at 12:34
  • What I've learned here is that any process starting with "store" probably has to do with the App Store and not some technical kind of "stor[ag]e"...killing all of them has whipped the App Store back into shape for me...any downside to the scorched earth approach?
    – Adam Lewis
    Jun 6 '16 at 15:16

I had a problem with not being able to stop an old OS from downloading. In order to delete it and stop the download, once opening launchpad, I held down the 'option' on my keyboard which caused the apps to wiggle just like on the iphone. I could then click the 'x' and delete them/stop the download.

  • 8
    +1 - My download for xcode was in waiting mode for days, first I was afraid of confirming the delete message after clicking the 'x' in a sense it would delete my xcode, but it didn't. It just stopped it from progress mode. Feb 10 '15 at 14:53
  • Worked brilliantly on OS X 10.10, when rebooting and "clearing caches" failed.
    – chipbuster
    Apr 4 '15 at 21:50
  • Thanks, @AdilSoomro, exactly the answer I was looking for! :) +1!
    – rmbianchi
    May 5 '15 at 7:29
  • 1
    You da real MVP
    – crmpicco
    Oct 16 '15 at 18:17
  • 6
    Worth mentioning that this also works in the app store itself - holding down option turns the "pause" button into "cancel".
    – Mikey T.K.
    Dec 14 '15 at 16:40

Do not delete or remove any downloaded part or file. Just do the following and it will resume the download.

In the Activity Monitor, for example, kill the storeagent process. Then restart App Store and click resume. That's it.

  • 26
    killing the storedownloadd process fixed it for me.
    – likebeats
    Dec 14 '15 at 18:38
  • 1
    storeagent didn't work, but storeddownloadd worked. I did it as: sudo kill -9 $(ps aux | grep storedownloadd | awk '{print $2}') Aug 30 '16 at 8:58
  • 8
    Killing them both did the trick for me: pkill -9 storedownloadd storeagent
    – ctc
    Oct 6 '16 at 1:34
  • 1
    This solved it for me, as there was no app in the launchpad, just a stuck app download in the App Store.
    – Remote
    Oct 1 '18 at 8:20
  • 8
    It seems storeagent has changed its name to appstoreagent in Catalina (full name in ps listings is /System/Library/PrivateFrameworks/AppStoreDaemon.framework/Support/appstoreagent). Jul 19 '20 at 10:41

Here's what worked for me:

  1. Open the launchpad
  2. Hold down on App that is stuck in "Waiting.." mode until it displays an 'X' in the upper left corner
  3. Press Enter and it should finish downloading or exit the infinite loop it's stuck in

Again, this is what worked for me, may not work for everyone but I thought I'd post it.


The actual downloads are done by a process called storeagent, which sometimes get stuck. Exit App Store, kill storeagent (e.g. in Activity Monitor), restart App Store (which will revive store agent) and go back to the Purchases tab where you click on the app to restart it.

  • 5
    I didn't see a storeagent but I did kill a few outer store processes (eg storedownload) which worked to reset things.
    – Nick
    Feb 2 '15 at 20:55
  • 2
    In macOS Catalina and above storeagent has been renamed to appstoreagent. Aug 17 '20 at 18:21

Thanks to Jason's response since it got me on the right track. The icon of the installing icon in LaunchPad would not, however, respond to double clicking. But when I selected and held the icon (as in 3 fingers on the trackpad) until all the icons started to "wiggle", then I could click on the "X" on the icon which halted the update.

The offending app was "XCode" and there is another topic on this site which refers to the problem with trying to update XCode via the App Store.


Maybe another apple ID logged in to the appstore - launchpad/appstore is still trying to update software that isn't linked to your apple ID. Log in using the original ID and complete or cancel the downloads, then log in with your own ID again.


All my iBooks downloads where in waiting mode too so I decided to kill storedownloadd (os x 10.10.3) which unstuck both app downloads.

  • I believe this is the best way to do it on 10.10/11.
    – Christian
    Dec 4 '15 at 0:09

With the latest update to Mountain Lion I am now able to fix the issue with ease. Now you can double-click a partially downloaded program to throw away all the currently downloaded parts and start over. This only starts working once the computer thinks it has stopped. I'm guessing there is some hidden timeout value that needs to be exceeded to enable this feature.

In one case (ClamXav) I had to reboot to get Mountain Lion to recognize that it wasn't downloading any longer. Double-click still worked to restart the download.

  • Accepting this one since it also worked for @David Brick
    – Jason
    Jan 30 '13 at 21:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .