Iphoto was acting strangely, and was unable to open a valid iPhoto library that worked just fine with another copy of iPhoto on an external drive created with Superduper from my original disk.

I'm running a mid-2010 MacBook Pro with Snow Leopard.

So, I deleted iPhoto and reinstalled from the disks that came with my computer, and ran Software Update. Software Update didn't notice that iPhoto was out of date. iPhoto won't run or open the iPhoto library, and Snow Leopard says it's out of date. Yep.

I deleted the receipts for iPhoto in /Library/Receipts. Software Update still didn't work.

I copied iPhoto from my Superduper volume. It's version 9.2.2, which is pretty current, but not completely up to date. It can't open my iPhoto library, even though it works fine when I boot from my external drive and use that same copy of iPhoto. OS X says it's not up to date, but Software Update doesn't know this and passes it over.

I'd buy iPhoto from the App Store, but the version there only works with Lion, which I can't install on this machine yet.

I'm sure this is confusing, but net-net:

  • Snow Leopard says my copy of iPhoto 9.2.2 is not up to date and won't open it.

  • Software Update doesn't recognize that iPhoto needs an update.

  • I'm out of ideas.

1 Answer 1


When you reinstall iPhoto 11 from disk:

Go to


Find and download the 9.1 updater. Run it. Then Run Software update again.

That will find the 9.3 update.

  • Thanks. That got me where I needed to be. After running the updater, Software Update didn't see it, but I ran all the subsequent updaters and iPhoto is now up to date. That'll hold me until I can upgrade to Lion.
    – Barry Parr
    Commented Jun 20, 2012 at 22:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .