21

I have various calendars from iCloud and Google and it's very often that an event will be deleted from Google calendar but the iPhone will still show it. The same calendar is on iCal on my Mac and it shows it correctly there. If it doesn't, I can + R or + + R to update it.

Maybe I'm missing the place or configuration to do the same on the iPhone calendar application.

5

EDIT: This has been fixed in recent versions of iOS. Please see @LukeWilliams answer which describes simply pulling to refresh the calendars in the Calendars list.


For deprecated versions of iOS: As of iOS 5 there is no super easy/obvious way to do this. What I have found that works, is opening Settings > Mail, Contacts, and Calendars > Tapping the email account you'd like to refresh > turn the calendar off > wait while it deletes it > turn the calendar back on.


sometimes by forcing a New Event, it triggers syncing.

  • 1
    This worked for me; unfortunately it means losing any local modifications (on the phone that haven't been synced). So if the reason you need to force a sync is because you've made changes on the phone that haven't synced to the cloud, this trick won't help. – metamatt Nov 5 '12 at 18:50
27

In iOS 7 and later:

  1. Open Calendar app
  2. Click Calendars
  3. Drag down to refresh
  • 3
    Works exactly as described, and is entirely non-obvious. Thank you! – Matt Ball Jun 20 '14 at 18:25
  • Worked on iOS 8.1 also, great! – haa Nov 5 '14 at 20:51
  • 1
    Didn't work for me on iOS 8.1.1 Used to work on iOS 7 though. – Artem Dec 1 '14 at 9:03
  • Didn't work for me in iOS 10.0.1 – mwengler Sep 21 '16 at 20:17
  • 2
    Worked for me on 10.3.3, but agree with @MattBall that it's very non-obvious. Remember when Apple UIs were the gold standard? Not so much these days. – Dave Land Oct 28 '17 at 3:56
5

On iOS 6 or earlier, my experience is that the easiest way to sync the calendars is, from within the Calendar App on the iPhone, tap the Calendar Button in the upper left corner. You now have a display with a grey Edit button in the upper left, A blue Done button in the upper right, and down at the bottom on the left is a white clockwise circular arrow. Tap it and it will sync the calendars.

  • I don't know if this refresh button is supposed to refresh the calendars themselves, or just the list of calendars (what's on the same screen as that refresh button). My iPhone stopped syncing my Google calendar completely -- updates stopped syncing in both directions -- and this refresh button didn't help. – metamatt Nov 5 '12 at 18:49
  • Worked for me. Had stale data (ie missing events from my corporate calendar), performed the above steps by Haiyaka, and the events showed up. – r00fus Sep 3 '13 at 19:46
1

I was able to refresh my google calendars on iOS 8 by clicking on "Calendars" on the bottom of the screen, then just swiping down, just like you would when refreshing your mail inbox.

1

I had this problem today and the solutions above did NOT work.

In my case the problem was I did not have calendars enabled for cellular data. Since I wasn't on Wi-Fi, my calendar was not updating.

The solution was:

  1. Go to Settings > Cellular
  2. Make sure Cellular Data toggle is turned on (shows green).
  3. Scroll down to Calendars & Reminders. Make sure toggle switch is turned on (shows green).

That solved it for me!

0

I had this problem in iOS 8. For some reason, all the events from my work Gmail calendar disappeared. What I did was go into the settings then into mail contacts and calendars and then selected my work Gmail account. I turned off the calendar, then turned it back on. Then I went back to the calendar, and it started to sync. Hope that helps

  • when you turn it off would it delete all your calendar entries? – Archimedes Trajano Apr 1 '15 at 15:00
0

If you open the iCal app on your phone, go to "Calendars" and swipe/pull down it will refresh it (you'll see the spinning circle thing). Refreshed and updated it right away.

-1

What solved this for me was:

  1. Turn calendar sync off and back on again.
  2. Re-enter your Apple ID password in settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .