30

I have a new MacBook Pro 13-inch (mid 2012). I have never liked the backlit keyboard. I am completely a touch-typist and I never look down at the keys. I just find the light going on and off to be annoying.

I have heard about Lab Tick, which provides a slider to control the level of the backlight, but what I really want is a command-line defaults write to simply turn the lights off.

Does anyone know of a means to do this?

  • The updated answer should be the one given by @PaulSmith – captainblack Nov 26 '16 at 21:21
23

Go to System Preferences -> Keyboard and, in the Keyboard tab, turn off (uncheck) "Automatically illuminate keyboard in low light". Then, if you turn the brightness down all the way, it should never turn on. If you then want it on (say, a friend who is not a touch-typist), just use the brightness keys on the top row.

  • Good enough. The lights still come on whenever I log out, and until I log back in again, and when I boot up. I suppose that's the best I can do. – user9290 Jun 13 '12 at 20:31
  • @WheatWilliams That's odd. I keep my backlight off nearly all the time, and I've never seen that happen. – CajunLuke Jun 13 '12 at 20:40
23

New for 2014: You'd think you should be able to take care of this in one location but, no.

  1. Open System Preferences, then open Keyboard, and in the first 'Keyboard' tab panel, uncheck "Adjust keyboard brightness in low light". Also here, be sure to check the "Use all F1, F2, etc. keys as standard function keys" checkbox so that your 'fn' key works. Close the panel.

  2. While holding down the fn key, press F5. You should see a semi-transparent control with a setting sun icon. Tap or hold until the bars go down to 0.

  • 7
    If you don't check the "Use all F1, F2, etc. keys as standard function keys" box, you can just hit F5 without using fn. – 0942v8653 Sep 6 '14 at 23:25
  • 1
    This worked for me on OS X 10.9 Mavericks - the accepted answer was not enough. Fairly poor UX to have to Google this much just to find this out. – RichVel Apr 1 '15 at 6:13
  • 1
    This should be the accepted answer! As an addendum: make sure you press F5 or Fn+F5 in the MacBook Pro keyboard — I was using an Apple Bluetooth Keyboard to do that and obviously it wasn't working. – AeroCross May 8 '17 at 0:01
1

Click on the fn button at the bottom left and then click F5, you can completely turn off the backlight by turning it low.

  • 1. Pressing fn+F# is incorrect based on default settings. 2. This answer has already been taken into account in the first answer back in 2012, and doesn't help if auto-enable is turned on. – grg Feb 10 '14 at 16:27

You must log in to answer this question.

protected by Community May 26 '18 at 18:30

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?