Running OSX Lion, I have no "connect to server" option listed in Finder > Go menu. Everything I've read about connecting to a Windows file share references that option. Why would it be missing and where did it go? I am trying to connect to a SMB share at work from my personal laptop, so there is no corporate policy file disabling that option on it. The network admin knows of no reason why it would be missing.

I hope someone can help with this.

  • Did you already reboot your mac? And create a new account und log in as the new user for once (to see whether it's a general problem or just with your account).
    – nohillside
    Jun 13, 2012 at 14:09
  • No, I have not tried that, yet. I will, though. Thanks.
    – Mike S.
    Jun 13, 2012 at 18:38
  • Are you running Onyx on your Mac? A posting here: forums.macrumors.com/showthread.php?t=1196874 indicates that this may be a problem.
    – IconDaemon
    Jun 13, 2012 at 18:44
  • I just tried your suggestion. Same result. No "Connect to Server" option. Test account had admin privs.
    – Mike S.
    Jun 13, 2012 at 18:45
  • I don't know what Onyx is, so most likely, "no".
    – Mike S.
    Jun 13, 2012 at 19:44

3 Answers 3


Chad, Thanks for the link. Petrock had the solution. Here it is:

I used the free Pref Setter app to edit the plist file.

You probably used one of those "set hidden finder features" apps/utils, didn't you... naughty person you is... If you open up ~/Library/Preferences/com.apple.finder.plist with Property List Editor and see an entry for "ProhibitConnectTo", then thats the problem. Set it to false and save the changes. Then Control-Option-Click on the Finder icon in the dock and select Relaunch. When the Finder comes back up, Connect To should be available again.

  • 2
    defaults delete com.apple.finder ProhibitConnectTo would have the same effect.
    – Lri
    Jun 15, 2012 at 12:09
  • The defaults delete option seemed to be all that worked for me on High Sierra.
    – alroc
    Dec 14, 2019 at 12:13

I have the same issue as you, no "Connect to server..." from Go menu, and Cmd-K also not work.

But I accidently right-click on Finder icon on Dock and see "Connect to server..." option from there. It works for me!


Make sure that you have Finder in focus and hit "Command K" and you should get the connect to server window.

  • 1
    I'm quite sure finder has focus. cmd-k does nothing.
    – Mike S.
    Jun 13, 2012 at 18:39
  • 1
    Note that command will bring up the "Connect to Server" window not fix the drop down menu to have the option listed in there again. I can't confirm for certain since I'm on my work Windows machine but this link will also prove what I say is true: support.apple.com/kb/HT1343 Jun 13, 2012 at 20:59
  • 1
    Hmm this might have been a more complicated problem than I frist thought try some of the suggestions in this disscussion, espically the last one. discussions.apple.com/thread/1735862?start=0&tstart=0 Jun 13, 2012 at 21:22
  • I'm not implying that what you say isn't true. Merely stating a fact that cmd-k does nothing.
    – Mike S.
    Jun 14, 2012 at 13:18
  • @ChadMarmon : Might you have meant to suggest "Shift Command K"?
    – EJ Mak
    Apr 15, 2021 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .