1

Installed Lion on a brand new HDD. Boots fine, but when I run Disk Utility on the Media, it reports

Verifying partition map for “WDC WD10JPVT-16A1YT0 Media” 
Checking prerequisites 
Checking the partition list 
Checking for an EFI system partition 
Checking the EFI system partition’s size 
Checking the EFI system partition’s file system 
Checking all HFS data partition loader spaces 
Checking Core Storage Physical Volume partitions 
Checking storage system 
Problems were found with the partition map which might prevent booting 
Error: Storage system verify or repair failed.

The "Error" statement was in red. Running the Disk Utility on the Lion partition in the same HDD reports no error.

Questions:

  1. Is this because I've enabled File Vault on the HDD?
  2. Should I be worried about the error reported by Disk Utility?
3
  • If you upgrade to Mountain Lion, does Disk Utility continue to display the same limitation? Commented Jul 29, 2012 at 9:25
  • Oddly the same error message does not appear using Disk Utility on OS X 10.8. Commented Jul 29, 2012 at 13:16
  • I see this error when using FileVault in Mountain Lion.
    – gentmatt
    Commented Sep 27, 2012 at 7:16

2 Answers 2

2

The error is not caused by enabling FileVault 2.

Context:

  • FileVault 2 uses Core Storage
  • to verify a logical volume that is in coreStorage world, Disk Utility will run both fsck_cs and more traditional fsck_hfs.

fsck_cs does not perform an exhaustive validation, nor is it able to fix many of the inconsistencies that it does detect.

That said, I should not be immediately worried about the class of error given in your question.

3
  • 1
    Thanks. Good to know. Oddly if I select the HDD (not the volume) using OS X 10.7's Disk Utility, the above error message appeared. Repeating this using OS X 10.8's Disk Utility, and no error message appeared. Selecting the volume to Verify using Disk Utility works on both OS X 10.7 and 10.8. Commented Jul 29, 2012 at 13:14
  • 2
    In Mountain Lion with FileVault 2, in Disk Utility look closely … where you expect to see a physical disk, you may instead find a logical volume group – the physical disk may be invisible. Commented Jul 29, 2012 at 13:33
  • In my particular case, I can confirm it's a LVG. Commented Jul 29, 2012 at 13:58
2

Yes, the error is caused by enabling File Vault only (Lion OS).

Please disable it and check it.

1
  • I can also relate this error to FileVault. When I disabled FileVault in Mountain Lion, the error disappeared. Upon re-enabling FileVault, the error came back.
    – gentmatt
    Commented Sep 27, 2012 at 7:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .