I don't want FaceBook to put any notifications on my iPhone's home screen for anything, ever.

I've gone into the iPhone's "settings" app and turned off all notifications for FaceBook.

I've gone into the settings within the FB app itself and turned off all push notifications.

But I still get notifications.

What more do they want from me?

3 Answers 3


If there is something FaceBook is good at, it's in bothering it's users :)
So make sure you've unchecked those items:

Make sure you've switched the Notification Center-slider to off and the Alert Style to none in such a way FaceBook is listed in the Not In Notification Center.

And if you go to Settings < FaceBook, make sure you're Push Notifications are all switched off.

  • Did it turn off your push notifications?
    – Michiel
    Jun 11, 2012 at 18:44
  • So far, yes. It appears to have done so.
    – Agvorth
    Jun 12, 2012 at 17:22

Settings -> Notifications

You have to choose none in the notification style menu, and disable all buttons.


Go onto the persons page that u want to block you notifications from then click "friends"/"add frien" and press notifications and when u press it,it will get rid of a tick on the right hand side! If in stead a tick appears. press it again to stop the notifications! hope this answer helped! thanks! :)

  • 1
    But OP wants iOS notifications turned off not FB notifications. And please use grammatical English in the answer so that it may be understood.
    – mmmmmm
    Feb 15, 2013 at 23:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .