6

I just want to use this shortcut for one other application.

3
defaults write -g NSUserKeyEquivalents -dict-add "Special Characters..." nul

Or change the shortcut to something else in System Preferences: enter image description here

  • Setting a shortcut to nil is a great trick, certainly more elegant than setting it to some obscure key combo. Unfortunately, anything set to nil in the Keyboard Shortcuts gets reset to L when you restart. So a script to do this added to your login items can avoid any inconvenience. – robmathers Jul 13 '12 at 0:47
  • @CanuckSkier At least on my installation of 10.7 the shortcuts set to nul are shown as L in System Preferences (as in the screenshot), but they stay as nul on the property lists and pressing L doesn't trigger them. – Lri Jul 13 '12 at 12:36
  • That's what I get as well, but I've had it revert on restarts to L actually triggering them. Perhaps there was a second factor causing this that I overlooked. – robmathers Jul 13 '12 at 19:22
  • @CanuckSkier I still can't reproduce that. A few applications like Audacity and Find Any File seem to think that menu items assigned to nul are assigned to N though. – Lri Jul 14 '12 at 16:34
  • Interesting. I'll have to do some more testing then. Thanks for the feedback. – robmathers Jul 14 '12 at 17:46
0

Going to System Preferences and selecting Keyboard preferences, and then clicking on the Keyboard Shortcuts tab will show a list. If you select Keyboard & Text Input, the shortcut (Cmd + Option + T) should be there, and just follow the directions to change it.

  • 1
    Hi Tanner, the problem is there are no mention of a special characters's shortcut in "Keyboard & Text Input". These are mostly about moving focus... But thanks anyway, I discovered one new cool shortcut. – politicus Jun 12 '12 at 4:26
  • Ah, I had forgotten. The comment below explains how. I didn't have access to a Mac at the time, but I knew it was somewhere in the system preferences. – Tanner Jun 12 '12 at 4:51
0

In Mojave, selecting an Input Source as "Unicode Hex Input" in [ System Preferences > Keyboard > Input Sources ] does the trick.

enter image description here

Note that when you click the + to add this Input Source it appears way at the bottom under "Others".

enter image description here

Make sure to enable "Show input menu in menu bar" and select the new input method from the menu bar since it doesn't seem you can make this the default from the Control Panel.

Unfortunately, this is not a great solution for anyone needing a layout other than the basic English one. Some might find it suitable to just use the menu bar to switch to this input source when needed (ie. coding) and back to the native one otherwise.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .