I've been trying to set up iChat screen sharing between an iBook G4 and my MacBook (both running the latest Leopard) for some time now without success. iChat has been configured on both computers with Jabber connecting to GChat (both accounts are GMail addresses). I've been able to get it to work when both computers were on the same network, but I get this message when I try to connect over the Internet:

Failed to start screen sharing because: screen sharing could not be established

Thanks, iChat. That's a lot of help. I do get this line in Console.app if it helps any:

No iChat delegate set for vcc:initiateConferenceCompletedForParty: 

Googling for this phrase yields only a handful of posts on the Apple forums, none of which are very helpful in addressing this problem. Is this a firewall/router issue? Is there a workaround?

Oh, and I do know that Skype now supports screen sharing on Macs, and I'm going to attempt to use it as soon as I can talk my grandmother through installing it (no easy feat, so I'd much rather have a fix for iChat)

1 Answer 1


Another thing to try is to use Screen Sharing directly. This means:

  • Turn on Screen Sharing from the Sharing preferences
  • If the computers aren't on the same network, set up port forwarding for port 5900
  • Open Screen Sharing from /System/Library/CoreServices/, type in the IP address of the other machine and connect.
  • 1
    This might work, but I cringe at trying to explain how to configure the router to forward ports to my grandmother. I'll put it in the list of things to try though, thanks :-). What does it mean if this does or doesn't work? Commented Jul 30, 2009 at 5:55
  • iChat can be finicky sometimes... if this works, then you should be good. Alternatively, you might look into LogMeIn, as it's easier to set up for grandmother types, since it involves no portforwarding.
    – jtbandes
    Commented Jul 30, 2009 at 6:17
  • 1
    @jtbandes: thanks for the suggestion of LogMeIn, if only so I can remote-control her computer long enough to set up the system preferences/port forwarding. Commented Jul 30, 2009 at 6:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .