When I use Terminal my computer says

Last login: Thu Jun  7 22:00:00 on ttys000
John-Does-MacBook-Pro:~ John$ 

That was the default account name on the computer when I bought it. I have been using it for 2 weeks now and I am pretty much set with the OS and I really don't want to do a reinstall. I deleted the John Doe account but that did nothing.

How do I change my Terminal so it doesn't display that any more?


In System Preferences, go to Sharing and change the name at the top of the window.

System Prefs>Sharing>Computer name

  • Perfect mate. For future viewers, quit terminal and then start it again to see the change. Jun 8 '12 at 2:37

I recently had the same issue and found a fix in a day. If this issue hasn't been resolved, follow these instructions:

If there's no HostName available, what you see is probably coming from the DNS or DHCP server.

Set your HostName with sudo scutil --set HostName 'yourHostName'

That should do it.

Why is my host name wrong at the Terminal prompt when connected to a public WiFi network?


Create a new "USER" -- named as you wish.

Move the entire contents of your current

User Folder to the new folder via Drag & Drop.

If you hold down the Command Key during

the operation, selected items will be MOVED,

as opposed to copied, aliased, etc.

Reboot while holding down the Option Key.

Voila !

  • 1
    I think Davisgeek's answer is a bit more practical. Apr 15 '13 at 2:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .