Sometimes I see the iMac with 4GB of RAM having a few MB of swap file only, and after I left for a few hours and come back, the swap file is 2.7GB.

Looking into the Activities Monitor, the Finder is using 796MB. How can it use so much memory -- could it be due to some "Search" that was left over in a Finder window?

I then chose File -> Close All (by pressing down the Option key while clicking File, and closed all Finder windows, only that it still won't close but just hidden, and looks like the only way is to reboot. How can this situation be prevented?

  • Will that swap space be automatically relinquished if some other process wants it?
    – GEdgar
    Commented Jun 7, 2012 at 16:22
  • It sound like memory leak. You should repport it the apple and try update. Commented Jul 18, 2012 at 9:14
  • deveneezer.blogspot.com/2012/11/…
    – cjahangir
    Commented Feb 6, 2018 at 7:20

4 Answers 4


I can't say much about preventing this, but there is no need to reboot. Just kill Finder, using Force Quit from the apple menu or killall Finder in a Terminal window. A new Finder will then be started in the old one's place.

  • 2
    but why should we keep having to do this? Commented May 13, 2017 at 13:45
  • Finder on Monterey has a (so far unrepaired) memory leak. Why Finder might leak memory on older versions of MacOS, I don't know. But the workaround outlined here will still work, even today. And no, that should not be necessary. Commented Mar 26, 2022 at 11:49

This inconvenience is caused by a finder prefs entry:

"show in new window: all my files" this is consuming too much mem. Select a different folder and all is fine

  • 7
    On my computer, changing this setting and following Harald's option reduced Finder's memory usage from ~1GB to ~70MB. Commented Nov 12, 2013 at 2:31
  • Same for me, from 700-800MBs to ~40 Commented Jun 13, 2015 at 2:05
  • didn't help me :-/
    – sgelbart
    Commented Jun 30, 2015 at 14:54
  • "Harald's option" isn't an option. It is force restarting Finder which will definitely free up RAM, but maybe just temporarily. It shouldn't be included with this option, they are very different things. Commented Nov 23, 2017 at 11:24
  • 1
    Where can this preferences entry be found? (In OSX 10.14 Mojave, in the Finder > Preferences window, I didn't see it under any of the General, Tags, Sidebar, or Advanced tabs.) Commented Jan 29, 2019 at 21:50

Removing 1k screenshots and images from the desktop reduced Finder's RAM usage from 1.5G+ to 220 MB instantly without relaunch.


I have found the following advice most useful to fix the issue of Finder using way too much RAM.

you may be a victim of a corrupt spotlight index. Here's how you fix a corrupt spotlight index:

  1. Open system preferences
  2. open spotlight (top right)
  3. click on privacy tab
  4. click and drag your hard drive into the window (if you have more than one, perform this one at a time.)

you will leave this in here for at least 10 minutes. no less. (seems hokey but osx does stuff behind the scene ie removing existing index)

after your 10 mins at least is up, go back in and remove your HD from the privacy tab, and osx should start rebuilding a new index.

repeat for any additional drives you may have. I would also close out of system preferences while you are waiting your 10 minutes.


  • 2
    This looks like a quote from discussions.apple.com, pleas always add a reference, take a look to referencing
    – bummi
    Commented Sep 20, 2017 at 12:53
  • I've added a link to what I believe to be the source. Always link the source.
    – grg
    Commented Mar 12, 2021 at 8:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .