I can't seem to get new users to access VPN on our OS X Server. If I use my login credentials with the VPN connection, everything works. But when I change to a recently created user I get a error window: "VPN Connection Authentication failed.".

OS X 10.7.4 VPN are set to L2TP.

Are there any hidden settings pr anything I am missing?


Have you somehow set things up so you need to add each new user explicitly to a security group to allow VPN? Check the Access tab in server admin to ensure all users are allowed to authenticate for VPN connections.

  • I have added the users manually there. No luck. I have also tried to allow everyone. No luck. – Mattias Jun 6 '12 at 20:40
  • Well - at this point, it's going to be tcpdump to see if the traffic is reaching the server and mucking in the vpn logs to see if there is some error that clues us in to the breakdown. :-( I'll assume you tested these accounts by connecting to the web based Profile Manager to ensure the user/password combination is being seen by an app that reads it from LDAP. – bmike Jun 6 '12 at 21:02

Have a close look at /var/log/ppp/vpnd.log and see if you get any clues there.

You might also want to open /Library/Preferences/SystemConfiguration/com.apple.RemoteAccessServers.plist in your favourite plist editor and have a close look at that.

I also assume you are creating the users as network users on your server using the GUI tool.

Do you have any standard users working? If you create another administrator user do they have access?


I also had one user which worked and one that would not authenticate. The problem turned out to be a ',' (comma) in the password. Setting up an identical user with a password that didn't have the comma corrected the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .