21

I use Apple's iMessage across several devices, including my (OS X Lion) Mac, using the recent Messages beta.

However, the application has some undesired behaviour.

When I quit Messages, it will relaunch itself when I receive new messages. This is incredibly distracting.

Is there a way to temporarily disable or mute iMessage (including the badge on the Dock) from just my Mac? I'd still like to receive messages on my other iOS devices.

  • Why do you want to disable the app and not just remove it? – Michiel Jun 6 '12 at 8:12
  • 2
    I enjoy using the app, it's helpful, and I'm a frequent user of the iMessage service. But there are times when I need to get some work done, and the frequent sounds, badges, and dock bounces aren't helping my concentration. – Redandwhite Jun 6 '12 at 9:51
16

An update for Mac OS X 10.9 (Mavericks). You can turn on Do Not Disturb in Notification Centre to mute notifications:

notification centre -  do not disturb screenshot

You can show Notification Centre by clicking on the three-horizontal-lines icon on the far-right of the menubar, or perhaps by doing a two-finger swipe from the right edge of your trackpad (if this gesture is enabled in System Preferences -> Trackpad -> More Gestures). Then swipe up to reveal the 'Do Not Disturb' toggle (which is hidden at the top of the notification centre panel).

Update: I've also just discovered that you can option-click on the Notification centre menubar icon to toggle Do Not Disturb mode on and off.

  • This is much better than having to disable iMessage every time and also keeps messages that come in while muted in iMessage which doesn't happen when it's disabled. – Ariel Nov 26 '14 at 16:38
  • 1
    This should be the new answer. – joshmcode Apr 17 '16 at 22:23
8

Click your apple symbol in the computer -> System preferences -> notifications -> messages -> none

  • 1
    UPDATE: New notification center settings enable this functionality. – Redandwhite Dec 16 '14 at 11:09
5

On the Messages menubar, go to Messages-> Accounts and uncheck iMessages.

3

In Messages, unselect the "Use Alerts in this Conversation" option in the View menu. This should enable iMessages without the sounds.

  • 1
    I like this option to mute that person basting you with messages. (Thanks for the edit @patrix) – iDev247 Feb 5 '14 at 20:55
0

If you want to silence a specific person / group (because they blast you while you are trying to work or whatever), but want to receive other notifications. You can click on "details" in the chat (in Messages) window and select "do not disturb".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .