15

I use SelfControl quite frequently for completing homework and such, but at school, while I was away from my keyboard at the white board, my friend thought it would be funny to set the timer to 10 hours. I am currently using a proxy to ask this question. Is there any way to disable this useful, but inflexible application?

2
  • 2
    As a note, you should have your computer to ask for a password before making changes. So when I activate my self control program, i have to put my password in first. This will prevent unauthorized of the program.
    – user51266
    Jun 14, 2013 at 15:34
  • 1
    the purpose is to not disable it Jan 15, 2017 at 2:09

5 Answers 5

22

Have you tried opening Terminal (Applications -> Utilities -> Terminal) and using the commands:

killall SelfControl

or

sudo killall SelfControl

As it is not working try the hosts file:

sudo nano /etc/hosts

And look for something like this

# BEGIN SELFCONTROL BLOCK
127.0.0.1   www.nasa.gov
127.0.0.1   nasa.gov
# END SELFCONTROL BLOCK

delete the entire block and hit CTRL + O to save the file and CTRL + X to exit. Everything you put at hosts file like:

127.0.0.1 facebook.com
127.0.0.1 nasa.gov
127.0.0.1 stackoverflow.com

Those addresses will be blocked, you will not be able to access them while they are inside the hosts file

To stop and delete SelfControl running as a background process:

sudo su -
cd /Library/PrivilegedHelperTools/
rm org.eyebeam.SelfControl

To delete the firewall rules that have been introduced by SelfControl, read this blog article by Joshua Kehn:

http://joshuakehn.com/2010/10/25/Defeating-SelfControl.html

9
  • Yes. It keeps running even when the application is closed, so killall won't work... Jun 1, 2012 at 0:18
  • Sorry I didn't understand you
    – msmafra
    Jun 1, 2012 at 0:21
  • I have the # BEGIN SELFCONTROL BLOCK and # END SELFCONTROL BLOCK. What should I do now? Jun 1, 2012 at 0:36
  • Delete the entire block and save the file. There probably be IP numbers and sites addresses inside the block. if you put: 127.0.0.1 facebook.com for example it will be blocked
    – msmafra
    Jun 1, 2012 at 0:44
  • Hit CTRL + O to save the file and CTRL + X to exit
    – msmafra
    Jun 1, 2012 at 0:51
18

Sometimes deleting what's between the # BEGIN SELFCONTROL and # END SELFCONTROL doesn't work.

On the other side, changing the Date or Time worked perfectly for me! All you gotta do is change your date to something in the future, for example if today is Sep 4 you can change your system date to something like Sep 5 !

  1. You open Preferences Open Date & Time
  2. Change the date to something like Sep 5 or any date in the future.
  3. Open SelfControl, the countdown will be gone now.

Try opening a website that you blocked with selfControl! if it does work! then it's all you gotta do ... otherwise try changing the date back to the original date (Sept 4) for example, and try again opening the website that you blocked with SelfControl!

2
  • You are genius!
    – alexmorhun
    Dec 22, 2014 at 11:09
  • could self control prevent this? Jan 15, 2017 at 2:09
7

It's simple, just open preferences, and change the date to the next day!

2
  • Changing the time does not work if you are connected to the internet.
    – user56848
    Sep 10, 2013 at 21:53
  • 1
    @Mindy How so? I change time often when connected to he network.
    – bmike
    Sep 11, 2013 at 4:13
7

I had to remove the lines in /etc/hosts, change the date in /etc/SelfControl.lock, and reopen the SelfControl application:

sudo sed -i '' '/# BEGIN SELFCONTROL/,/# END SELFCONTROL/d' /etc/hosts
sudo sed -i '' 's|<date>.*|<date>2010-01-01T01:01:01Z</date>|' /etc/SelfControl.lock
killall SelfControl; open -a SelfControl

Just deleting /etc/SelfControl.lock didn't work. If you have removed SelfControl.app, download it again first.

1
  • At 2020 it is the only answer that works, maybe they update their security policies, Thanks! Feb 7, 2020 at 15:22
5

Update: This still works in 2021

Quit SelfControl.

Open System Preferences > Date and Time > Change the day 1 day in the future.

Launch SelfControl again. Quit SelfControl and then change the date back.

This works because SelfControl checks the date and time, sees that you are past the blocking period, and removes the host file additions.

4
  • 1
    Can confirm this works. Jul 10, 2016 at 17:56
  • what about in 2020 Aug 23, 2020 at 16:14
  • @SuperUberDuper It still works perfectly.
    – Sam Wong
    Mar 18, 2021 at 13:22
  • dang its too easy then( Apr 3, 2021 at 18:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .