2

I am running Snow Leopard 10.6.8 on an early 2010 15" MacBook Pro. After restarting from scratch (what I don't do often usually) my trackpad is set back to "click" instead of "touch".

This started happening lately and I suspect this came with an update.

Is this a known bug and/or is there a solution to this?

  • 1
    Maybe OS X is trying to tell you that you shouldn't use tap-to-click because click-to-click is inherently better? (This is intended as a joke, but I do prefer click to tap.) – Cajunluke May 31 '12 at 19:45
3

The symptoms you describe are caused by the preference not getting saved to disk. Sometimes the cause is that there is a problem with the file permissions (as per thaatz's answer). Another possibility is that the preference file somehow got corrupted; if this is the case, you can move the preference file (I think the relevant one is ~/Library/Preferences/com.apple.driver.AppleBluetoothMultitouch.trackpad.plist) from its location: this will cause the preference file to be recreated. Of course this will work also for other preferences (though identifying the correct file isn't always as easy); remember to keep the file around (instead of deleting it) so you can restore it in case this fix doesn't work.

  • 1
    As mentioned below this solved the problem. Thanks! – greenforest Jun 10 '12 at 14:31
2

Perhaps it is having problems writing and saving your settings due to some sort of permission error. Have you tried verifying and repairing disk file permissions? (use disk utility)

  • +1 and thanks for the tip. I tried it but unfortunately it didn't help to solve the problem. – greenforest Jun 9 '12 at 8:42
  • 1
    it's probably this. If repairing permissions didn't help, try moving away the ~/Library/Preferences/com.apple.driver.AppleBluetoothMultitouch.trackpad.plist so it gets recreated. – Agos Jun 9 '12 at 12:09
  • @Agos Is this setting about the external trackpad? My problem is about the build in one... – greenforest Jun 10 '12 at 11:52
  • @Agos I tried to repair the disk file permissions and restarted but it didn't help. But your suggestion worked. Why don't you turn your comment into an answer? – greenforest Jun 10 '12 at 12:26
  • @user12999 glad it worked. I added an answer below. – Agos Jun 10 '12 at 13:58
0

Your trackpad settings are not applied in the login screen, log into an account an they will be restored to that accounts settings.

  • 1
    Right, it's an account setting - but it doesn't work after I logged in – greenforest May 31 '12 at 6:18
  • Hmm that's strange, maybe you're experiencing some sort of bug. – Mick MacCallum May 31 '12 at 8:04
  • Hm yeah, that was part of my questi – greenforest Jun 2 '12 at 22:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .