Whenever I try to do a software update on OS X Snow Leopard, it gets to the point where it says it needs to restart, goes to the spacey background, and then sits there indefinitely.

I've tried booting from the OS install disk and doing permissions and file repairs (which did find and supposedly fix problems), but it still hangs.

Now I'm trying to update from the command line using sudo softwareupdate -i -a. For maybe 10 minutes, it's been stuck at "Writing files..."

In a different terminal window, I ran tail -f /var/log/install.log to see what it's doing. There it has hung at this:

Patching System/Library/CoreServices/BluetoothUIServer.app/Contents/MacOS/BluetoothUIServer

Is there anything I can do to fix this other than a full wipe and reinstall?


With verbose output (the -v flag in sudo softwareupdate -i -a -v), I could see the program's progress in terms of percentages. The higher it got, the slower it went. It was repeating 99% when I left it for the night. In the morning I found it had been repeating 100% for hours. Time to try something else.


5 Answers 5



I was able to fix this problem by downloading and running the Mac OS X 10.6.8 Update Combo v1.1.

After this ran and I restarted, I was able to successfully run Software Update, from the command line or the GUI; it now tells me that there is no new software to install.

Before doing this, I did check for I/O errors as @SethNoble suggested, then run the utilities that @Stephen suggested. I did not find any problems, although I had previously run Disk Utility from my OS X install disk and repaired both permissions and files.


It sounds like maybe the hard drive could be having trouble. I would recommend running Smart Utility. If the smart status says that the hard drive is ok then try running Disk Warrior. Let me know if either of those things work. I had the same problem once, if your hard drive is badly fragmented it has trouble installing things.


I went under details after you hit software update and removed everything that is checked in boxes except the system update. That worked for me since I only wanted system update not iTunes and etc.


Accessing "Show Details" of the Software Update and installing the updates one at a time solved the problem in my case.


Note that some updates can take an hour or more, particularly if your hard drive is near full or you have a lot of files. Many take more than 10 minutes.

In your system log, check for I/O or media errors. Do not run disk utility or Disk Warrior until after you have checked for I/O errors. See this article for more details: Recovering from I/O and Media Errors

If all else fails, look in /Library/Updates/. Move everything in there to another folder (perhaps on your desktop). The Finder will need your admin password to do that. Then reboot and try Software Update again.

  • I don't see any IO errors in the log or console. May 29, 2012 at 17:10
  • I gave softwareupdate 1.5 hours before stopping it. Not sure about fragmentation but, I'm only using about 35 out of 500 GB. Now running it with the -v flag. May 29, 2012 at 17:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .