I am endeavoring to use the MacBook Pro to broadcast its Ethernet Internet connection as WiFi, in order to access this connection through my iPhone.

I have made the following configurations:

Internet Sharing: System Preferences

I have configured the Internet sharing network to employ WEP pass phrases et al.

In my Network Preferences, I have configured the Wifi to have a manually configured IPv4 Protocol with being the Router, a DNS name server, a class C Subnet mask.

In my iPhone device, I have configured it as a Static IP configuration for the Wifi, with being the MBP's IP and being the iPhone's IP, with a class C Subnet Mask with a DNS name server, being the router and local.lan for the Search Domains field.

The issue is: There is no Internet connectivity in the iPhone device. The device reports "Check if you have Internet Connectivity and try again"

iPhone 4 with iOS 5.1
MacBook Pro with Lion 10.7.4

Any insights into how this can be resolved?

3 Answers 3


I use my MacBook Pro to share internet to my iPhone and my friends' iPod Touch.

Make sure that you're using WPA2 to secure your network, not WEP- I have had issues connecting my iPhone to WEP networks, and they're not only less secure but the password is more annoying to type anyway.

Other than that, your IP schemes are also not compatible. You need to set the devices to have the same IP scheme; if your WiFi is set to a address, your iPhone needs to be Setting both to DHCP would help a lot here.

For my setup, I just left everything as DHCP and don't have any issues.


You may need to check the firewall setting on your MBP. In System Settings -> Security -> Firewall.
When I was doing this I just disabled the firewall and that seemed to work.

  • If I'm not mistaken, once the option for sharing the Ethernet Connection through the Wifi option is chosen, will not the Firewall implicitly make an exception for said port?
    – meh
    Jun 1, 2012 at 11:53
  • I am unsure of how the firewall works in OS X. I know you can add programs to the list of allowances. I am unsure of what program you would add to allow "Internet Sharing." When I set this up last night I had to Disable then Re-Enable the firewall before any of my devices could connect. (Possibly a bug in OS X?)
    – JMFR
    Jun 6, 2012 at 19:05
  • Could you double check that disabling the firewall fixed a problem within 10.7.4? Because the traffic enabled through InternetSharing doesn't pass through the Application firewall (it passes through pfctl which lets everything pass through).
    – dan
    Sep 10, 2012 at 14:21

I advise you to onfigure your iPhone to use an IP address attributed with DHCP.

When you turn InternetSharing on, this will turn on 2 processes on your MacBook Pro:


The 1st one is also a DHCP server and will attribute a predefined IP address to your iPhone.

If this does solve your problem, please say so.

If not, please stay on DHCP configuration, since this is the way it should work with InternetSharing. In this last bad case, this is simply the evidence that the problem is somewhere else, and some more investigation will be necessary.

As an exemple, once DHCP is settled on, you can check within your system log on your MacBook Pro that your iPhone gets a correct IP address.

Just type the following command within a Terminal or xterm:

grep DHCP /var/log/system.log

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .