1

I have my iPod set up to only sync certain playlists, so that I don't fill up the whole thing. However, iTunes keeps on losing my sync settings for my iPod across syncs. It doesn't remember any of the settings I set at all and I have to go back and check all the playlist again...etc. How can I fix this, as it is really annoying (and a big hassle)? I've tried restoring the iPod, repairing permissions. There are two other devices synced to my iTunes, an iPod nano, and an iPad.

Update: The recent update to iTunes (10.6.3) doesn't seem to fix this issue.

6
  • 1
    Have you tried restoring the device? Repairing Disk's Permissions? Have you got any other device synced to that iTunes?
    – Thecafremo
    May 28 '12 at 9:40
  • @Thecafremo I'm sorry, I should have added that. See my updated question.
    – daviesgeek
    May 28 '12 at 15:24
  • 1
    I understand that the other two devices sync correctly, right? Does any of the other devices share the name with the problematic one? Did it ever worked correctly?
    – Thecafremo
    May 29 '12 at 13:27
  • @Thecafremo Yes. No. Yes. :-)
    – daviesgeek
    May 29 '12 at 16:05
  • What generations are said devices, and what software versions are they running?
    – user14395
    Jun 18 '12 at 15:24
1

It seems like the problem was when I enabled disk use in my iPod's settings:

Unchecking this box seems to have fixed this issue. I haven't had a problem since.

2
  • 1
    I'm glad that I'm not the only one who found that disabling "Enable disk use" clears up that exact problem. Very annoying, but that does the trick. iTunes continually lost my iPod settings, unchecking things that I had previously checked to sync. Nothing remedied it, not even "restore." Unchecking that box worked. BTW, I am using the latest (last) iPod classic 150 GB model.
    – user37495
    Dec 29 '12 at 12:33
  • @Mark yup, it drove me nuts! Then I figured out that was the problem...works like a charm now!
    – daviesgeek
    Dec 29 '12 at 23:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .