6

When I open System Preferences and click on an item it says 'Loading Users & Groups' at the top of the window, but will not load the pane.

I've tried deleting the property list file:

 /library/preferences/com.apple.systempreference.plist 

I also tried clearing the PR and booting in Safe Mode. Anyone have any other ideas before I wipe and re-install?

thanks mcgrailm

  • I'm adding the text "Could not load Time Machine preference pane.", copied verbatim from the sheet I see on System Preferences when this happens to me. I hope that will help people searching. – D A Vincent Oct 8 '16 at 7:31
2

Have you looked in the console? Maybe you'll find some error messages there which can narrow the problem down. You can view log files in Console, located in /Applications/Utilities.

Have you tried to check (and maybe repair) the file rights. You can do this with disk utility.

About Disk Utility's Repair Disk Permissions feature

  • yes rean disk utility first fixed all sorts of problems there gonna look at console now – mcgrailm May 23 '12 at 20:37
  • logs says "PreferencePanes folder is missing" I guess that can't be fixed without re install ? – mcgrailm May 23 '12 at 20:46
  • To be honest i am not sure. Haven't tried to delete my prefs folder :). Maybe you can use Time Machine to restore the folder? – Pfitz May 23 '12 at 20:50
  • ha good point , doubt they had time machine running but thats a good thing to try thanks for your help – mcgrailm May 23 '12 at 20:52
  • just checked: directory for system PrefPanes is : /System/Library/PreferencePanes – Pfitz May 23 '12 at 20:54
2

Boot in single user mode (Hold down SHIFT key right after hitting the power button until the Apple Logo appears), Login, Launch System Preferences, Load the Preferences Pane that is not working, Restart Mac OS X. That worked for me when nothing else did.

  • 1
    Shift is actually Safe Mode, but the rest is certainly worth a try. – Tetsujin Apr 15 '15 at 6:40
  • Edited to explain single-user mode based on content from Mac Help. – D A Vincent Oct 8 '16 at 8:43
0

Restart, Hold Shift key right after your screen shut down to run safe mode, go to display preferences again to check if is can be opened, and then restart -> Done, I tried and it worked on OS 10.12.3. p/s: I found out this solution of Claeton in this post. Thanks a lot!

  • While I was able to get back into the preference panel the issue returned again but a few moments later I tried and was able to open Time Machine Preferences. So I can't say this is a resolution. – Tunes Jul 11 '17 at 0:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .