The Skype app requires me to constantly launch it if I want to receive any messages on my iPad. Switch away, and a couple of hours later it goes offline and stops receiving messages/calls. There is of course no indication whatsoever of whether it's still running in the background.

Is there a fix for this? Is this a bug in Skype that can only be fixed by Skype developers, or is there something I can do about this? Like some sort of a setting to allow Skype to stay open in the background.

2 Answers 2


Took me a lot of time to discover you have an option in iPhone (iPad) Settings app, you scroll down until you find Skype, and there you have the option to go offline automatically. Make sure this is set appropriately (e.g. to Never).

I'm running last version available today, 23rd of may 2012, both IOS and Skype. Solved my problem few weeks ago.

  • I don't seem to have this option. The settings page you refer to only shows options for "Sign In Automatically" and "Allow Targeted Ads". Any ideas? [running iOS 5.0.1 and Skype]
    – sffc
    Apr 19, 2014 at 5:05

Hello to all and namaste, I had this same problem I could not get my skype online ie it had a permanent cross, I did a lot thing on Ipad 4.

This what I did on setting,

Go to setting On the alert style I changed to ALERT a few day ago without any joy,

Today on ALERT Below in SHOW IN NOTIFICATION CENTER I turned it off and I was online, I then turned it on and was still online

I am now waiting for someone to call me, hope his helps

  • Could you please clarify the exact steps that you used to solve the problem? What exactly did you change?
    – grg
    Jan 25, 2014 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .