I have a Windows server (Win 2003) not using AD, just a simple local file server.

My Mac clients can log in fine to the server using SMB in the Connect To Server window on the Mac, and they can access files fine, but I can't find any way of changing their server password from their Mac.

A few years ago, we would go into the Mac's Terminal and type:

smbpasswd -r <serverIPaddress> -U <username>

the server would ask for the current password, then allow the user to specify a new password. But with the last few versions of Mac OS X (Leopard & Snow Leopard?) this doesn't seem to work anymore - and now with Lion smbpasswd isn't even included!

Is there some other technique to change the user's server password on the Mac?


You could install Samba3 through Macports and then you'll have smbpasswd available again.

  1. Install Xcode from Apple - If you download Xcode from the Mac App Store, be sure to use the Xcode preferences to subsequently download the command line tools or use the xcode-select tool to get the BSD command line tools placed in your path. MacPorts needs make, gcc and other tools from Xcode to compile the samba3 code.
  2. Install Macports for Lion (or whatever OS X version you are using)
  3. Run sudo port -d selfupdate - just to be up-to-date
  4. Install Samba3 in Macports: sudo port install samba3
  5. Setup smb.conf: sudo cp /opt/local/etc/samba3/smb.conf.sample /opt/local/etc/samba3/smb.conf

You are done, and now you should be able to call smbpasswd -r <serverIPaddress> -U <username> again.

| improve this answer | |

Does the server has Remote Desktop enabled? If so, your users could open an RDP connection to the server and change their password.

You could also use this workaround, as Lion (as you wrote) does not comes with smbpasswd.

| improve this answer | |
  • Thanks, I just tested the first method and it does seem to work, although most of our users are not currently authorized to use Remote Desktop. The second method is very clever, but I haven't tried it. – Steve Rothman May 22 '12 at 19:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .