2

Often I'm listening to the songs being imported during the import, using the new tracks in the library. When iTunes completes the import there's an annoying finished chime that sounds loudly because I'm listening to music.

There doesn't appear to be anything relevant in the prefs dialog. Web searches weren't helpful, and I've looked around in itunes prefs files but nothing looks useful there either.

I'm hoping that there's an undocumented plist pref.

I use iTunes on a Windows 7 machine.

EDIT: @daniel-lawson approach seems to be the only way to solve this.

  • Searching for filenames beginning with complete in the iTunes directory, I found: C:\Program Files (x86)\iTunes\iTunes.Resources\complete.wav
  • If you might want to reverse this in the future, make a copy of complete.wav
  • Truncate/Empty complete.wav somehow.
  • No more Import Complete sound.

Alternately just delete complete.wav. I prefer to keep the filename in the directory; maybe this will prevent a software update from re-creating it.

After looking around a bit more using the filename, I found this issue addressed on forums, and the answer seemed to be: delete the file. Also, someone has written a GUI around this that probably just edits the file: I Hate That iTunes Done Chime!

1

On iTunes for Mac, the file /Applications/iTunes.app/Contents/Resources/complete.aif contains the finished chime; if one were to remove the file, it couldn't play. I don't have access to a Windows computer with iTunes, so I can't say where that file would be, but a similar tactic could work.

  • I found C:\Program Files (x86)\iTunes\iTunes.Resources\complete.wav and truncated it. This addresses my issue, but I'm concerned about this file being recreated during a software update, and would prefer a prefs solution. If none is forthcoming I'll accept this answer. – pb2q May 20 '12 at 19:02
  • 1
    It is not on the list of known hidden preferences of iTunes. It's hard to prove a negative, but the Secrets database knows about 22 hidden preferences for iTunes 10, and that isn't one of them. – Daniel May 20 '12 at 19:08
  • secrets.blacktree.com? I'd forgotten about that, thx. – pb2q May 20 '12 at 19:12
4

I found the answer here, and it worked for me on Windows 10. Instructions copied just in case the website goes away:

  1. Click Start then Control Panel
  2. Type sound into the search box at the top of the Control Panel and press Enter
  3. Click the Sound link from the Control Panel. The Sound properties window launches
  4. Click the Sounds tab
  5. Scroll down the list of available sounds in the iTunes section. There are two sounds associated with iTunes: Complete and Page Load Complete
  6. Click the iTunes sound that you want to turn off
  7. Select None from the drop-down box under Sounds. Click Apply
  8. Repeat Steps 6 and 7 for each iTunes sound that you want to turn off
  • 1
    This works great, and without the need to edit or remove the files so they're there if you ever change your mind. – NanoCarp Feb 9 '17 at 20:55
0

In iTunes 12 you have to truncate/delete the complete.wav file. The listing in Sounds/Sound Effects for iTunes no longer works. They are blank (no sounds) in Windows 10 with iTunes 12.

Thanks for the info on the complete.wav file, this works great! Apple really should put that in Preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .