1

I installed Windows 7 using bootcamp on my Early 2011 MBP. I gave 130GB to Win7 and rest to Mac HD. Once all was done, I created a new partition within Mac HD. The partition was created successfully but when I restarted computer and pressed "option" key, I was not able to see the Windows(boot camp), only Mac HD and Recovery HD.

How to fix that, is it not possible to have further partition after boot camp? Coz if I created partitions earlier to boot camp, boot camp assistant gives error of making one single partition.

need urgent help on this.

4
  • Same problem over here. Did you ever find a solution?
    – 3Dave
    Jun 26, 2012 at 15:23
  • I suspect your GPT and Hybrid MBR partition tables might have gone out of sync, or your bootcamp partition got removed from the MBR (but not GPT) because of the 4-partition-limit. Can you post the output of the following terminal commands: diskutil list disk0, sudo gpt -r show disk0, and sudo fdisk /dev/disk0 ? (these will show the partition layout as OSX sees it, and the the raw GPT and MBR partition tables, respectively)
    – pmdj
    Jul 2, 2012 at 17:45
  • have you actually installed windows or did you only partition the hdd in the boot camp assistant? Mar 11, 2014 at 8:44
  • Bootcamp is not officially supported with extra partitions (Beyond the MacHD, Bootcamp & Recovery). As noted other places, you can get it to work, but it may stop working with the next update. This is covered all over the place here and elsewhere. Depending on why you want another partition, your best solution might be to get an external drive instead (which BTW Bootcamp won't work with either.)
    – sdmeyers
    Jul 25, 2014 at 13:01

1 Answer 1

1

I also faced similar issue and was able to solve with post on apple discussions.

However follow these instruction carefully and make sure to have all backups in place.


Based on comment below, adding answer in post


sudo gdisk /dev/disk0

If you get any error messages at this point, report the error messages, don't proceed further.

You're now in gdisk interactive mode. Menus/commands are single characters followed by return/enter. So type ? and  and you'll get the main menu listing commands. Type p  and it will print (display) the current GPT. Since you have 5 GPT entries, you can't use a 1 for 1 GPT to MBR scheme like Apple does. The following suggestion is safe, but all hybrid MBRs are non-standard inventions, and therefore I can't tell you how Boot Camp Assistant or Disk Utility will react to this hybrid MBR should you decide to make changes later. What I can tell you is Windows, Linux, and Mac OS X themselves have no problem with this MBR scheme.

r         go to the recovery & transformation menu
h         create a new hybrid MBR
5         add partion 5 to the MBR
          accept the default MBR hex code of 07
y         set the bootable flag
n         do not protect more partitions
o        print (display) the MBR

You should have two entries. One type EE, one 07, with the 07 entry marked with * under Boot. If you don't, report back. If you do, write out the update partition information, and hope  a power failure doesn't occur for the next few seconds...

w      write partition table to disk

reboot. hold down option - you should be able to boot into either Mac HD, Recovery HD, or Windows.

I just tested this same five partition GPT and 2 partition MBR on a working system and the instructions above worked.

Note, so long as CSM-BIOS and thus MBR are required for Boot Camp instead of EFI booting Windows, we're stuck with flaky MBR problems, as well as the 2TB disk limitation for Windows boot disks.

Also, I filed bug ID 11980880 at bugreport.apple.com and referenced this thread.
3
  • yes thats true grgarside... I tried to add answer here, but then figured that it exceed the max character limit also, doesn't allow me to press enter to insert new line. What should be other way.
    – devilzk83
    Oct 19, 2013 at 3:41
  • Under your post, above these comments on the left is an edit button - you can use this to edit your post.
    – grg
    Oct 19, 2013 at 8:33
  • Thanks. I was trying to add post text in comment earlier :) Now edited original answer post and added <pre>answer from that link</pre>
    – devilzk83
    Oct 23, 2013 at 4:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .