0

I am on OSX Lion. After I Control C the building of Atlas under MacPorts Clang I can no longer get it to run. It start taking around 2GB on startup and even does this after a reboot. After killing the terminal the first time an error report was sent to Apple. The second time killing it did not trigger such a request. What do I need to do to get the terminal to run again in a normal fashion?

1

You can try deleting Terminal's saved application state. It's in ~/Library/Saved Application State/com.apple.Terminal.savedState. You can also try deleting Terminal's preferences. Those are in ~/Library/Preferences/com.apple.Terminal.plist.

If you don't want to potentially lose the saved state or preferences, you can move them to the desktop before starting Terminal.

In Lion, you can get to ~/Library by holding the Option key while selecting the Go menu in Finder.

  • I removed ~/Library/Preferences/com.apple.Terminal.plist and restarted. The terminal does open now. It still uses 815.8 MB memory and 5 threads while I only have one window opened and am not running any commands. But perhaps that is normal? PS Nice trick with the options or alt key and Go. Did not know! – rhand May 20 '12 at 6:43
  • 815.8 MB sounds like a lot. Mine is currently only using 19.0 MB (but is using 5 threads). Have you tried removing the saved state? – SSteve May 20 '12 at 6:48
  • I managed to fix it. I closed the terminal. Opened it. Then just closed the window with the saved state - many lines of compiling code were saved running sudo port -d upgrade outdated - and then opened a new window. Now it is just using 34 MB :-) – rhand May 20 '12 at 6:53
  • Mine is running 5 threads too, but is using ±31 MB Intel (64 Bit). That is OK, right? – rhand May 20 '12 at 6:59
  • That doesn't sound unreasonable. – SSteve May 20 '12 at 15:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .