Is there a way to select icons (using the keyboard) that aren't directly touching? In Windows, I'd press Ctrl+Down, but it doesn't work in the Finder view. I've tried all the usual keyboard shortcuts, but it doesn't seem to work. I can multi-select other icons just fine, but I can't multi-select these two.

The picture explains it better than I could. The icons in this folder are aligned to the grid.

finder view

  • Since it is not working as I expected it, I have deleted my answer ^^
    – strauberry
    May 19, 2012 at 13:14
  • Shift + down should work. It does for me. Can you check and confirm?
    – Nivas
    May 20, 2012 at 3:35
  • Apparently it works only if the view is not sorted. See my answer.
    – Nivas
    May 20, 2012 at 3:54
  • Have you tried shift + right?
    – Alexander
    May 20, 2012 at 5:18

4 Answers 4


You could use cmd ⌘ + 2 to change to the list view and then just use Shift + Down.


I thought Shift + Down should work. I tried and the results were, let us say, special:

When your view is sorted by Name, Shift + Down does not go the last item.

If your view is not sorted, (Sort By: None), then Shift + Down selecs the last item as well.

See this screencast. (This is my first screencast, so not a very good one)

  • I tested with Sort By: None as well as Name in Sierra 10.12.6. Neither works.
    – wisbucky
    Apr 1, 2018 at 15:48

The answer, it turns out, is fairly unintuitive.

  1. Select the last item (the PSD).
  2. Press Shift + Up.
  3. Hold Shift and press Right repeatedly until you get the selection you want.
  • That doesn't work in Sierra 10.12.6. Using spreadsheet coordinates, If I select A2, then pressing shift+up will select A1. Then pressing shift+right will select B2, C2, D2. You end up with an "L" shape.
    – wisbucky
    Mar 31, 2018 at 16:03

Selecting multiple icons with the keyboard in Finder's Icons View is very limited. Here's a few options:

cmd+click: This definitely works in Icons View, but you have to use the mouse to click.

shift+arrows: This only works properly in a single row or a single column. If you start trying to use the arrow keys to select more than a single row or column, you'll get inconsistent and strange results.

The only real solution, unfortunately, is to switch to List View to do the multiple selection.

Some people mentioned that Icons View keyboard selection works when not sorted, but my testing on Sierra 10.12.6 found that it didn't matter whether Icons View was sorted or not, keyboard selection didn't work beyond a single row/column.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .