Here is the setup: I have the Applications folder right in the dock, which is the default after installation afaik.

Now I have a custom build DMG with an application in there which I drag&drop into the Application folder. When I open the Application folder from the dock and look for the newly installed app, it does not have the application icon it should.

The App is custom build as well. It uses the info.plist to specify the icon file to be used - which is called cc.icns and located in the Contents/Resources folder

I think this might be a problem with the icon cache and can be resolved by logout/login - a solution that I'm not looking for. Afaik there are apps that do not have this problem. (Right? Wrong?)

Any suggestions on this?

  • 3
    does it show the default icon (pencil/paper) with a circle and line through it? Dec 21, 2010 at 8:48
  • Yes, thats right.
    – gamma
    Dec 21, 2010 at 9:36
  • 2
    That happens with every application I install until I've confirmed I want to open it. Sometimes it takes one, sometimes two times of opening the app before the real icon shows up. Dec 21, 2010 at 17:26
  • @gamma I've had no problems adding custom icons to apps before. Have you tried logging out and back in? Have you tried restarting? Is this what the relevant lines in your .plist look like: <key>CFBundleIconFile</key><string>cc.icns</string>? Dec 21, 2010 at 18:30
  • @calavera I think that is what I'm experiencing as well. @matthewpavkov yeah, the line looks like mine. The question is how to avoid the logout/login/restart procedure.
    – gamma
    Dec 22, 2010 at 7:31

3 Answers 3


If you want to avoid the Login/Logout, restarting the dock should be enough: killall Dock from the Terminal should be enough.

  • Thats not quite the thing either, since I can't call it from the "Drag&Drop" routine which is done by a user - not me. It has to be something that can be done from the ".app" folder or via the Info.plist.
    – gamma
    Dec 23, 2010 at 9:25
  • I thinking out of the box but you could create an AppleScript, that does that, and that it gets executed everytime you create a NEW item in the Application’s Folder (Folder Actions). Dec 23, 2010 at 14:23
  • I believe that's what MS does when installing Office 2k8. Jan 6, 2011 at 11:54

In other words, to conclude the answers I've seen to date, there is no such solution without taking further action since the systems security mechanisms is built that way.


Apparently there's an application that takes care of the quarantining 'problem' - that is, when an application is first installed, OS X will not launch it without approval from you, the first time only.

There is a utility that can get around this called Deeper. (http://www.titanium.free.fr/download.php)

Or you can copy/paste this into terminal. defaults write com.apple.LaunchServices LSQuarantine -bool NO

(Source: http://hints.macworld.com/article.php?story=20071029151619619)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .