I'm on a Macbook Pro (mid-2009) running Lion 10.7.4. Everything has been awesome these past few years, but something weird started happening a month ago: my copy/paste has been acting oddly. Sometimes I copy text and when I paste, it would be something I had copied earlier. I chalked this up to an incorrect keystroke on my part. But even when I pay attention closely this still happens somewhat infrequently.

Even more bizarre is when I cut text (just to be sure my keystrokes worked), I would see the text disappear, but when I paste what's in the clipboard, it would paste something older. huh? I'd then have to undo a few times to restore the text I cut out.

I've ruled out hardware issues with my keyboard since this happens even when I do it with my mouse (using PopClip which pops up iOS style copy/paste buttons).

I am not running any clipboard utilities so I am stumped. If this is a hardware issue, I'd love to know that soon because my AppleCare runs out in a few weeks. Thanks for any tips or leads.

  • 2
    It's almost definitely not a hardware issue (though it never hurts to go bother your local Apple Store Geniuses). Does it seems to be happening more often in some apps than others? A few months ago I noticed Eclipse would fail to copy from time to time, but that seems to have gotten better of late.
    – Cajunluke
    Commented May 17, 2012 at 17:35
  • I've tried to hone in on that but no, it is not application specific. Happens in most text editors and Google Chrome as well. I can't figure out it it's some specific application that's causing this behavior.
    – Maiasaura
    Commented May 17, 2012 at 17:50
  • Then it's probably different than what I had; that was pretty clearly an Eclipse bug.
    – Cajunluke
    Commented May 17, 2012 at 17:56
  • I had a similar problem, it was mostly between Safari, and other applications that I was having problems. I found restarting my computer solved it.
    – zevlag
    Commented May 17, 2012 at 18:43
  • alas not such a simple fix. I've restarted dozens of times since the problem started.
    – Maiasaura
    Commented May 18, 2012 at 1:54

2 Answers 2


Do you have several user accounts setup on your Mac ? Does it occur on every account ?

The idea here is to find out if the issue is specific to one user or is affecting the whole system.

If it just occurs on your session, you could try to delete the contents of the Library/Caches inside your Home folder. No need to delete the folder, just put its contents to the Trash. Then log out/log back in or reboot your Mac.

  • I agree with this and @cajunluke that you'll want to get help isolating a software cause. It can't hurt to get the hardware checked, but you will want to re-examine your description as stated since you say you have no copy software yet clearly have pop clip installed.
    – bmike
    Commented Sep 13, 2012 at 18:12

Given that this is almost certainly not a hardware issue (there is, after all, no copy/paste chip that performs that function) and given the troubleshooting steps you have included, this still sounds like a task for your local Genius Bar. If it's a configuration issue or a software conflict, they can help you sort it out, and if it's a bug in OS X, they'll make Apple aware of it so it can be fixed.

As other answers have mentioned, you still have to isolate software as a cause by trying a new user or a new install of the OS (perhaps to an external drive).


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .