The answer is not as simple as you might think at first glance; please read the details of my question.

I know the difference between Standard Function keys and Special keys. Standard Function keys are F1, F2, F10, etc. whereas the Special keys are "Decrease Brightness, "Increase Brightness", "Mute" and so on.

When the "Use all F1, F2, etc. keys as standard function keys" option is turned off in Keyboard Settings, pressing the key that is located to the right of the Escape key will lower the brightness, but pressing it while holding down Fn will trigger an F1 keypress (and whatever F1 might be mapped to).

Conversely, if the "Use all F1, F2, etc. keys as standard function keys" option is turned on, the F1 key will trigger an F1 keypress, the F2 an F2 keypress, etc.

Now that I've established that, please consider the following situation.

I have an Early 2011 13" MacBook Pro. It has a Launchpad special function on the F4 key (it looks like a 2-by-3 grid of squares), rather than the Dashboard special function like the older pre-Lion MacBooks had. However, for some strange reason, when I activate that special function, instead of showing Launchpad as expected (this is what I want) it activates Dashboard.

I am NOT asking for how to fix this problem using a walkaround, for example by mapping F4 (the standard function key) to open Launchpad. I already know how to do that. Instead, what I'm asking is this:

Question: How can I fix my MacBook Pro so that the Launchpad special key performed the correct function of opening Launchpad, instead of doing something else (opening Dashboard).

(I realize it's not a big deal and I typically use the touchpad gesture to launch Launchpad, but nonetheless I'd like to fix this if possible)

I've reinstalled OS X Lion 10.7.3 from scratch on this MacBook, but nothing has changed.

Any ideas?

  • I think your question is a duplicate of apple.stackexchange.com/questions/24352/… ...have you tried the solutions there? – Nix May 17 '12 at 3:20
  • I think you may be right. I just found a similar solution here: discussions.apple.com/thread/3243844?start=0&tstart=0 I'm gonna try it and report back. – Dmitri Shuralyov May 17 '12 at 4:31
  • Hmm, unfortunately, I don't think that's it. I tried deleting that ~/Library/Preferences/com.apple.symbolichotkeys.plist file, restarting, no luck. I've logged in to a guest account, and the Launchpad key still opens Dashboard. Since I got this MacBook Pro used from someone, perhaps he originally had a Dashboard key and then replaced it with a Launchpad key? – Dmitri Shuralyov May 17 '12 at 4:48

You must log in to answer this question.

Browse other questions tagged .