Today I tried to format my SD cards with no success. The only thing different that I did was updating to 10.7.4 this weekend. What can I do to re-enable this function?

The can't format part means I can't format to any filesystem. It shows "read only". The erase format is not enabled.

Another user here has confirmed the same problem. The SD cards in question format fine in a camera but I can't write to it when I plug it into MacBook Pro. This started to happen only after update to 10.7.4. The problems seems to stem from (or correlate with) Disk Utility greying out all options apart from 'verify disk'.

Inserting SD card to SD -> USB dongle works just fine, so it's only SD card slot which seems to have assigned 'read only' status.

It's weird it started to work fine for a while and again I can't write to or format the SD cards.

I've formated a SD card with both exFAT and FAT32 and tried to use it on my laptop with Linux and guess what happened? It was read only even in another computer, but I've formated it again using Linux utility and everything is fine. But the SD saga continues on OS X Lion, as well as Mountain Lion and Mavericks.

It is annoying buying an Apple product and have this kind of headache, and the worst is that I don't have the possibility of walking in an Apple Store and ask a genius to solve it for me.

  • 2
    How are you trying to format the card? Disk Utility? Command-line tools? What file system are you trying to format to? What SD card reader are you using? – Cajunluke May 15 '12 at 21:48
  • More details might be helpful here. What actions did you take to try and format the cards? Have you checked the lock tab is not set? – binarybob May 15 '12 at 21:48
  • I have the same problem. I can easily format SD card in the camera but can't write on it when I plug it into MacBook Pro. This started to happen only after update to 10.7.4. You can't do much in Disk Utility as all options apart from 'verify disk' are greyed out. Anyone any ideas? I need to update FW version of my camera but can't copy FW to SD card so am left with no option to update my camera. – hexx May 16 '12 at 9:51

There are two likely possible causes for this:

  1. It's a hardware fault that just showed up, or
  2. It's a bug in OS X 10.7.4.

The best fix for both of these (currently) is to visit your local Apple Store's Genius Bar. In case 1, they'll fix your SD reader. In case 2, they'll pass the bug in OS X up the food chain so it can get fixed in 10.7.5 (they'll probably try to fix the hardware, too, just in case).

  • Thanks but there is no Apple Store in my country. I use the SD cards in my ultrabook. – msmafra Oct 26 '13 at 13:42
  • Also, sometime later using linux on the same machine I was able to read and write to SD cards. – msmafra Feb 2 '19 at 22:53

I think I may have figured it out. In Disk Utility while the SD card was plugged in I went to ##GB APPLE SD Card Reader Media Tab . The only thing I was allowed to rename was RAID, so I renamed it and literally all the grey-outs went away.
Try it to see if this helps. But you should try the above Terminal solutions before this...


I figured out a hack to fix this. By default, OS X Mountain Lion mounts the SD card as read only. You can get Mountain Lion to change the permissions to read-write as follows:

  1. Open a terminal window.
  2. Figure out the name of your flash disk, which is probably /Volumes/Untitled
  3. Run the following command:

    mount > /Volumes/Untitled/fred.txt
  4. This causes the OS to make the SD card read-write. Now, delete fred.txt

    rm /Volumes/Untitled/fred.txt
  5. Now copy whatever you need to to the card.

Also, make sure that the physical write-protect switch on the card is not set to read-only.

  • Those terminal commands don't work because of the original issue. Terminal returns the error "read-only file system." – user32981 Oct 16 '12 at 20:57

I have a mid 2009 MBP 15in. 8gB memory. I experienced the same problem. I tried a couple different SD cards and all I got was read only. I battled this issue for awhile and nobody (Apple or Mac Store) could figure it out. I took my MBP into an Apple store and had them restore back to 10.6.8. I tried another SD card and same thing. Finally, I took the SD card and used my wife's W8 machine. I formatted the SD FAt32. I put it in the MBP and finally I was able to read/write to the card! I'm not savvy enough to understand the why, but it worked. Now I'm anxious to try the PNY 128gB SD card.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .