When I attempt to SSH to anything from my iMac (SSH, git, etc.), SSH freezes at debug1: SSH2_MSG_SERVICE_ACCEPT received. This only happens on my account; I created a new account as a test and everything worked fine. I did reinstall SSH, but both accounts use the same executable. I can SSH to my computer from other computers, so I'm assuming that the problem lies with ssh and not with sshd.

SSH version: OpenSSH_5.9p1, OpenSSL 0.9.8r 8 Feb 2011
OS X Version: Version 10.6.8 build 10K549
Log: http://pastebin.com/wrugsYhf (I use a custom port, 7742)

Is there anything I can do? Thanks in advance.


Running unset SSH_AUTH_SOCK in Terminal worked for me, though I'm currently unsure why. One thing I did not mention in the body of my question was that I had to modify /System/Library/LaunchAgents/org.openbsd.ssh-agent.plist in order to get sshd to work: here's a link to my org.openbsd.ssh-agent.plist in case anyone in the future thinks they know what caused the problem.

  • Your link to the plist is broken (Sept. 20, 2015) – Jonathan Komar Sep 20 '15 at 14:26
  • This worked for me on Windows when Git SSH operations in PowerShell were hanging, but when using Git-Bash. You'll need to do rm env:\SSH_AUTH_SOCK, then subsequent SSH operations in that session will work. It doesn't seem to write a new value to SSH_AUTH_SOCK so this fix isn't permanent and I'll need to figure out what's setting that. Interestingly, the SSH_AUTH_SOCK var ended with a different pid than the SSH_AGENT_PID value. I'm guessing at that for the reason for failure. – FLGMwt Apr 4 '16 at 15:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .