I have a 1TB Western Digital external hard drive that I use for Time Machine backups, and recently my iMac has started to randomly eject the hard drive, preventing backups. It tends to happen while the display goes to sleep, but I have my Energy Saver settings set to not put the hard drives to sleep, and the computer is set to never go to sleep.

To correct the issue, I pull the USB cable on the drive and then re-attach it. I'm wondering if this is just a bad drive that I need to return or if this is some kind of larger issue.

  • 1
    Which OS? What model is the Mac? What model is the Western Digital drive? USB 2 or 3? Details from System Information will be ideal … thanks. Nov 1, 2012 at 10:17

5 Answers 5


Someone reported a similar issue on an Apple discussion forum:

I tried that but the drive will still eject itself randomly at times.

I contacted Western Digital about this and they say it might be a problem with my USB cord. So they're going to send me a new one.

Has anyone else had this problem and found that it was due to a faulty USB 3.0 (compatible with USB 2.0) cord?

Another poster in the same thread commented:

Sounds like disk is on the way out. I would move or backup all data on it.

You should first back up that drive before anything else. Contact WD to see if they can send you a new USB cord. It's a good idea to run some diagnostics on the drive to confirm that there are no disk errors. Testing on another computer would also be a good idea to narrow down to see if the issue is isolated to your machine or the drive.

If the drive is failing, you'll need to return/exchange it.


I had a similar problem with a 1TB 2.5" WD USB drive. It started to get randomly ejected while the MacBook was writing to it. Drive diagnostics didn't show any problems, reconnecting the drive didn't help. The simple solution was a reboot of the MacBook. (It hasn't been rebooted for about 2 months).

  • I would recommend you always reboot at least once a week. It keeps the machine running smoothly and eliminates many bugs. It also allows certain updates to take effect. Oct 20, 2021 at 19:46

Customer Reviews: Western Digital 1TB My Book for Mac - Apple Store (U.S.) include some comments that are thought-provoking.

If Western Digital software is installed, try uninstalling.

If you can, use the Western Digital web site to see whether the firmware for your drive is current.

(Western Digital's link to My Book Essential no longer works.)

Other Stack Exchange questions that involve Western Digital connectivity include:


I've hit this problem multiple times, invariably when I am writing large amounts of data to the drive (Time Machine, Retrospect, or Carbon Copy Cloner backups). Once it starts happening, it seems to keep happening, and only formatting the drive fixes the problem, and even then it seems to reoccur.

I have just tried using Disk Utility’s Erase Free Disk Space, and that seems to correct the problem, which is odd, but so far I haven't had a reoccurrence with the afflicted disks once I did this, so crossing fingers, hopefully this helps for real.


I had this same problem and it seems that the drive may have been underpowered. I may be wrong, but I got a powered USB hub and a new surge protector and everything worked out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .