1

I have a 27" iMac (2009) running the OS X 10.6.8 and using the Apple Wireless Keyboard. Since around March or early April, I noticed that the function keys (F1-F9) have stopped working. I think it started with one of the recent software updates.

Now, I can no longer control the brightness or media playback with the keyboard function keys. Looking at the on-screen keyboard, it's like the F1-F9 keys are not even registered by the OS. The volume keys (F10-F12) do still work.

While I can still control the brightness in System Preferences, this is still a big problem for me because when I try to use the iMac in target display mode with a MacBook Air (2011), the iMac goes to full brightness and I cannot adjust it down anymore with the keyboard buttons like I could before. This makes it unusable as a secondary display.

I have tried a lot of stuff but nothing seems to help. I have noticed a few posts on the Apple support forums with similar problems but there doesn't seem to be a resolution yet.

Things I've tried so far:

  • restarting computer
  • PRAM reset
  • SMC reset
  • disconnecting and re-pairing the keyboard
  • replacing keyboard batteries
  • using a different keyboard
  • repairing disk permissions
  • toggling the "Use F1,F2 keys..." setting

Another weird thing I noticed is that now the keyboard defaults seem to be mapped weird - it says that the brightness controls are mapped to F14/F15 when I don't even have those keys. And some of the other functions like Dashboard also got their defaults to different keys.

If I try mapping the brightness controls different keys such as F11/F12, I get the "invalid input" beep when I try pressing them.

Anyone know what could be going wrong?

  • When 'Use all F1, F2, etc. keys as standard function keys' is checked, do the function keys actually work as normal? If you check in the keyboard viewer, does it look like the system is seeing the keypresses? (For keyboard viewer, check the 'Show Keyboard & Character viewer in menu bar' in keyboard preferences, and then 'Show Keyboard Viewer' from the icon in the menu bar.) – Nix May 10 '12 at 22:51
  • Have you managed to resolve this? – Kevin Farrugia Aug 7 '17 at 9:50
1

Have you tried Change Keyboard Type in System Preferences -> Keyboard?

enter image description here

  • Can you elaborate on what you might change it to and how it might help with this problem? (My MacBook Air that has this problem doesn't have a Change Keyboard Type button, but maybe I can get at it some other way.) – LarsH Aug 30 '18 at 13:37
0

To change the command, instead of double-clicking the entire line, simply highlight F14 and rename the command to whatever you decide (I changed it to the up arrow), then do the same for F15...

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.