5

Whenever I try to open a new terminal window in iTerm, it closes right away after displaying this:

## exec failed ##
argpath=login error=No such file or directory

Does anyone know what is causing this? Thanks!

Notes

  • The terminal is working fine
  • The default command for new iTerm sessions is set to Login shell
5

Not sure why it didn't work with Login shell selected, but I changed it to ⌘ command and invoked bash -l or /bin/bash -l to make it work the same way. Hope this helps anyone else who has the same problem!

enter image description here

  • In my case, I updated my system, and the update included "command line fixes", after rebooting iTerm didn't work. Changing the preferences as described by CMDabado fixed my problem. I've updated the answer to include a screenshot. – OscarRyz Feb 24 '15 at 16:27
1

I had the same error, and the cause was that my PATH variable wasn't set correctly (I had meddled with it). Restoring a proper value using setenv fixed the issue. If you have meddled with your launchd path, you must edit it with launchctl.

In a terminal:

launchctl
setenv PATH /usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin

You may have to add the path to your /etc/launchd.conf file, and restart your computer as well. See https://stackoverflow.com/questions/135688/setting-environment-variables-in-os-x for more information.

  • 2
    Please guide us how to set the right value. – Rob Apr 14 '14 at 9:26
  • Y'a right, here you go!. – Martin Apr 17 '14 at 8:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .