0

OS X Lion 10.7.3.

Console view of system.log shows log entries for cron jobs defined in my user crontab as expected. Follow this link to view a copy of my user crontab if you want.

I inspected /usr/local/cron/tab as root and the system copy of my crontab is also as expected (the job entries are exactly the same as what I see when I do crontab -e).

Here's my question: every now and again I see a message like this in system.log:

May 7 02:36:17 echo mcook[70156]: mcook cron job PATH is /Users/mcook/local/bin:/Users/mcook/local/bin:/opt/local/bin:/opt/local/sbin:/sw/bin:/sw/sbin:/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Home/bin:.:/Users/mcook/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/usr/X11/bin:/usr/local/mysql/bin:/usr/X11R6/bin:/usr/X11/bin

I am puzzled because I can't find a matching cron tab entry for this. It's my user name, but none of the cron jobs I have in my user cron table just says echo "PATH is $PATH". The message appears at odd times, but I can't see an obvious pattern: yesterday at 04:23:59, today at 02:36:17 and 02:47:22

Where else can I look to find out where this is coming from? Could the cause be some old data hanging around in some .plist somewhere?

My crontab says "The periodic and atrun jobs have moved to launchd jobs see /System/Library/LaunchDaemons". I checked those and the files in /etc/periodic but I still did not find a possible cause.

Does someone have other suggestions as to where this might come from?

-1

launchd holds files in ~/Library/LaunchAgents for individual users.

  • I only have these in ~/Library/LaunchAgents: com.adobe.ARM.*.plist* com.apple.AddressBook.ScheduledSync.PHXCardDAVSource.*.plist (two) org.virtualbox.vboxwebsrv.plist* – cooker47 May 7 '12 at 20:40
  • 1
    I found the answer to my own silly question. Found the following redundant statement in my own shell script nsu-syslog (part of my weird and wonderful [nsu][1] utility that I run from X nearly every time I start it): logger mcook cron job PATH is $PATH At one time I tried running that script as a cron job (see the last job, commented out, in my user crontab listing). You can't start an xterm from a cron job, of course. I'm not advertising, honest. Just having a senior moment. [1]: sourceforge.net/projects/nsu – cooker47 May 7 '12 at 21:29
  • 4
    You should add that as an answer – zwerdlds May 21 '12 at 18:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.