In Mail on iPhone 4, with software update 4.2.1, it seems my Trash icon has been replaced with "Move to Folder". Is there someway to get the Trash icon back, so I can delete messages with one keystroke instead of two? I use Gmail IMAP.


It sounds like you might have the Archive button switched on. The latest update assumes you would prefer to archive than to trash.

If this is the case, Go to Settings > Mail, Calendar, etc.. > Gmail Mail Account > deactivate Archive button.

  • This especially would be the case on Gmail - if you set it up using the Gmail icon on mail setup, it automatically sets Archive vs Delete.
    – jmlumpkin
    Dec 20 '10 at 13:12
  • I tried this solution but it keeps defaulting back to "archive", I can't seem to reset it to "delete". Any advice?!
    – user64239
    Dec 6 '13 at 16:15

You must log in to answer this question.