Using the open command from terminal I would like to be able to specify the chrome the specific chrome user to open the url with? Local Chrome users are outlined here.

Essentially I have a local chrome user which I use for testing but the user which the local Chrome user which link opens with is the user which has the last selected window and jumping back and forth between chrome and the terminal often the link I am opening for testing end up opening in the chrome user which I use for practical purposes (not testing).

  • 1
  • That link looks very promising but each time a run any chrome command as specified I receive the folloing: $ /Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --remote-debugging-port=9222 \n [0506/035142:INFO:breakpad_mac.mm(148)] Breakpad disabled \n [15398:-1409084736:2001131272496316:ERROR:process_singleton_mac.cc(102)] Unable to obtain profile lock.
    – rudolph9
    May 6, 2012 at 8:53
  • Had the same. Did you try it with Chromium or Chrome stable channel?
    – bot47
    May 6, 2012 at 17:01
  • From the same page: 'The constant GOOGLE_CHROME_BUILD must not be defined'. It's probably safe to assume that it won't work with Chrome.
    – nohillside
    May 14, 2012 at 5:52

1 Answer 1


Have you tried open http://[email protected] and edit the question based on what error or success results from this step?

  • 1
    Untested suggestions such as this really go in a comment.
    – rudolph9
    May 6, 2012 at 3:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .