30

When creating either an Aggregate Device or a Multi-Output Device in Audio MIDI Setup and setting it as the default audio output device, the volume control is greyed out and locked at maximum intensity. Why is that and how can it be bypassed?

  • Same problem here. If I am correct this happened after I messed with the "configure speakers" and played around with the multichannel, even though I got nothing attached to the computer related to that. – user25739 Jul 25 '12 at 18:08
  • I'd hate to have to open Audio MIDI Setup every time I want to change the volume. Is there any chance this UI issue may be overcome by a third-party app like Boom 2? – Merchako Jan 2 '17 at 18:21
12

Whilst I'm not certain why the single volume control in the Sound preference pane is greyed out (or whether that behaviour can be changed), the only way I found to allow me to change the volume at all was to manually adjust the "Master" volume slider for each device in the aggregate or multi-output device.

  • Ooops, I'm late. But yeah, that's pretty much the only method I found, too. – arik-so Jul 25 '12 at 18:11
9

It's weird the inside the Audio MIDI Setup, I get the Master slider grayed out even if not using the Multi-Output device. Please, let me know if any better solution exists (or at least a workaround to my disabled Master slider).

My current solution is using Soundflower as suggested here by Jeremy at the end:

The final issue to resolve is having the ability to change the audio volume like normal. Unfortunately, I didn’t find a way to do this without the help of a 3rd party app, but thankfully, Soundflower seems to do the trick without any extra bloat and appears to be well maintained. It’s hosted on Github and you can find a download link both on Github and it’s Google Code home. Once you install it, you will find two new audio devices are listed in the Audio MIDI Setup app. For my purposes, the two channel device fit my needs, so I went in and set it as the default for both input, output, and system alert sounds (right click on the device and you will see options for each). You don’t have to do all three, but I found it works for my needs, so might for yours too. Once you have done that, launch the Soundflowerbed app from /Applications/Soundflower and then look for a menu bar icon shaped like a flower. Click on it, and then pick your Aggregate Device as shown here:

->image<-

With that, you should now be all set. Try hitting the volume change keys on your keyboard and confirm everything is working.

I hope this helps, as it helped me!

3

When using the Built-in Output as part of a Mult-Output Device, you can set the volume of the Built-in Output with AppleScript:

osascript -e 'set volume 2'

This doesn't seem to affect the volume of the other devices that are part of the Multi-Output Device.

Now, if only there was a way to get the volume button keys to run a script!

  • There is using ControllerMate – theonlygusti Jun 11 '17 at 17:19
  • 1
    Using this only seemed to adjust the volume of my bluetooth headphones but not the built in headphone jack, in my case – uglycoyote Jan 13 '18 at 5:58
1

This is a paid, but very robust solution to this problem: https://staticz.com/soundcontrol/

I'm using it in combination with SoundFlower which allows me to record program sounds.

0

The only fully functional and painless solution to this I have found is to use Rogue Amoeba's Loopback. In it's interface you can route audio to multiple audio devices and set the volume of each, or route to a multi-output device already set up using the Audio Midi Mac app. Both solutions retain system volume keyboard control and work perfectly. I opt for the former method since it is easier to adjust volume for individual devices in the Loopback interface.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .