I had a bunch of songs on iTunes that didn't have artist names, so consequently, I didn't have artist names on my iPod touch. I added artist names to all the songs I have on iTunes and now the artist names are not even showing up on my iPod. It just says "Artist Unknown" I really have no idea what to do. Can someone help me?

  • I assume you did sync your iPod after changing the names in iTunes. Are you using iTunes Match? – nohillside Apr 29 '12 at 10:01
  • Yes i did sync it after changing the names...and I'm using iTunes 10, not match – Molly Apr 29 '12 at 19:22
  • This is making me mad >:( – Molly May 10 '12 at 1:05

I faced the same issue after upgrading my iPod touch to iOS 5.1.1. I ended up restoring it to factory settings, and setting to auto-sync with iTunes (I ordinarily prefer to sync it manually!). I also had to change not only all "artist" names but also "album artist" names, as the new software appears to list the music according to album artists.


I had the same weird problem. After you download a music or something, be sure to check if the file is "read only" in properties. just uncheck it, make you changes on the file (album artwork, composers, album name etc.).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .