I feel stupid asking this, but my thorough troubleshooting and Google searches rendered no clues…

I'm trying to get to grips with Vim (MacVim) and I've set up Keyboard Maestro to automatically switch to US Extended when MacVim activates – conversely switching back to Swedish Pro when leaving MacVim.

(Works flawlessly and is very neat since Vim's default shortcuts poses a fair amount of discrimination towards non-english users.)

Dismayingly, however, when using US layout I couldn't find a way to type a simple + character… Anyone out there (presumably swedes but others too) who can shed some light on this?

  • + is Shift+= on a US keyboard if that helps... – jtbandes Apr 27 '12 at 12:24
  • 1
    hced, please do not feel stupid. We are happy to help with your question. – user9290 Apr 30 '12 at 21:16
up vote 1 down vote accepted

It should be Shift + ´ on a Swedish keyboard.

  • For me, pressing Shift+´ renders this char: . (I.e. if I press the key next on the left side of Del.) – Henrik Apr 27 '12 at 14:59
  • It's just very strange... If I open the Keyboard Viewer (Tangentbordsvisning) while having US Extended activated, then press Shift, the + char shows up under the key to the left of Del (that you referenced). The strange thing is that it won't be typed if I press Shift+´, nor will it be even if I click on the + with my mouse. – Henrik Apr 27 '12 at 15:19
  • Oops. My bad. I've isolated the problem (which was caused by a macro in Keyboard Maestro). Closing the question as answered, thanks. – Henrik Apr 27 '12 at 15:23

As a general tip, enable the Apple Keyboard & Character Viewer and you can see all the characters that will be produced by the specific model of keyboard that you have, using the specific software keyboard layout that you are using. Hold down the Shift and Option keys, and both at once, and you can see what the results will be.

enter image description here

enter image description here

Apple Keyboard Viewer in action

Apple Keyboard Viewer in action

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.