1

There used to be a checkbox when I import pictures from my camera that said "delete after import" or something like that. It's not there anymore. Any ideas?

1

If the media is write protected, or if the device is not providing full USB drive functionality, then deletion would not be possible and so might not be offered.

  • But it used to work before... – nute Apr 29 '12 at 10:27
  • Turns out it fixed itself magically today. No idea... – nute Apr 29 '12 at 10:31
1

If Image Capture detects that the device uses iCloud Photo Library, it disables 'delete after import'.

You can tell when the program starts the option shows, then a split second later, when the iCloud icon shows up next to the device, the 'delete after import' option is gone.

Here are some work-arounds:

On your device, go to Settings > iCloud > Photos > and then turn off iCloud Photo Library. This of course has larger repercussions (photos are no longer saved in the cloud).

In Image Capture, with your device connected, select all the photos you want to delete and then -Delete

1

This was a very annoying thing for a long time until I decided to FIX IT.....

I fixed it by replacing the cable - I use an original SHORT apple cable to connect the phone to my MAC :)

I tried everything and this what did it for me. Good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .