Whenever I start MacVim, a window opens that is not a buffer and doesn't seem to do anything - it doesn't react to any input at all, even - and that is the annoying part - the Mac OS X close button doesn't do anything. The window is just there and silently stares at me.

enter image description here

I already tried installing MacVim from scratch and completely deleting all .vim* configs, to no avail.

Any ideas?

  • What are you typing to open MacVim? Or are you using a shortcut? – MrDaniel Apr 24 '12 at 19:37
  • Did you remove the .vimrc file as well? located in your Mac OS X user home directory? It is separate from the .vim/ directory that is also in your home directory. – MrDaniel Apr 24 '12 at 19:39
  • Are you running the latest milestone with Lion capability? I've noticed older mac apps open lots of windows on Lion because of some weird "open the last window you had open" feature. – davetron5000 Apr 24 '12 at 19:45
  • What version of Mac OS X are you on and what version of MacVim are you running? – MrDaniel Apr 24 '12 at 19:45
  • It's MacVim 7.3 on OS X 10.7.3 – Manuel Kießling Apr 24 '12 at 20:03

Seeing how you have tried to delete all the normal preference files relating to vim settings, ~/.vimrc, ~/.vim there is one more thing to try and that is the Mac Os App specific preference files for MacVim. One good candidate is the MacVim plist file named org.vim.MacVim.plist. A corrupted version of that file may be causing the random window to appear.

First thing quit MacVim.

Then delete the MacVim related plist files.

You can use the terminal and the following command to help find the MacVim preferences related files. find / -name ".vim."

The org.vim.MacVim.plist file should be located at:


You might also want to delete: org.vim.MacVim.LSSharedFileList.plist

If the extra 'dead' window problem still exists when you reopen MacVim, then try deleting additionally some more files, this time some Cache and Lion Saved State Related files, along with other related files. Again Quit MacVim before deletion of any of the files, to prevent re-saving of the corrupted state of the program.

I observed the following other MacVim related files in the find search results, that you can try deletlting to attempt to resolve the issue:



/Users/<username>/Library/Saved\ Application\ State/org.vim.MacVim.savedState
| improve this answer | |
  • the solution seemed to delete a file called Library/Preferences/org.vim.MacVim.plist.lockfile... thank you for the insights – emgsilva Oct 28 '13 at 9:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .