12

I recall that the Character Viewer showed me the Unicode value of any character I selected, but now it doesn't show it anymore.

screenshot

How do I make it show the Unicode value as before?

If that makes any difference, I am using Mac OS X 10.7.3.

21

In Character Viewer, click the gear icon in the top-left, then select "Customize List".

enter image description here

In the dialog that appears, scroll to the bottom and check "Unicode" under the "Code Tables" branch.

enter image description here

You should see something like this if you click on the "Unicode" item that's now in the left-hand pane (with unicode hex values down the left-hand column):

enter image description here

Alternatively, you can also right-click the character and select "Copy Character Info".

enter image description here

Then, if you paste into a text editor you get:

A
LATIN CAPITAL LETTER A
Unicode: U+0041, UTF-8: 41
  • 2
    Once you have added the Unicode item to the list at the left, you will also see the Unicode value of all characters that you select even when you are NOT in that category, e.g. when you select Arrows instead. – Tom Gewecke Apr 26 '12 at 19:57
  • Thank you. Lack of Unicode info would have been a major annoyance. Glad to know it's still there. – Marnen Laibow-Koser May 29 '13 at 15:55
0

binarybob's answer is absolutely correct. I want to supplement it by adding a bash one-liner to enable this without using the Character Viewer GUI — useful, for example, in setup scripts:

defaults read com.apple.CharacterPaletteIM CVActiveCategories | \
    grep -q Category-Unicode || \
    defaults write com.apple.CharacterPaletteIM CVActiveCategories -array-add -string Category-Unicode

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .