Here's my setup:

I have a set of Altec Lansing FX5051 speakers that I run through the USB port. I also run VMWare Fusion (sometimes in Unity mode, sometimes single window, I don't think it matters) during the day for my work on a MacBook Pro.

At the end of the day, I unplug my speakers (and a few other things) and take the laptop home for the night. I leave VMWare running, since there's no performance hit.

In the morning, I go back to the office and plug the speakers back in. However, when I attempt to listen to my music or podcasts, the sound comes out of my internal speakers. If I press the ALT key while clicking on my speaker icon, the Altec Lansing speakers are not listed. I should note that the speakers are listed as a connectable USB device from within VMWare.

So far the only solution I've found has been to shut down VMWare, unplug the speakers, and then plug them back in. On a couple of occasions I've been able to use VMWare Fusion to attach the speakers to the virtual machine, then detach them, and then it will show up, but this is not consistent. I've also tried using the USB Probe and the device does show up there, just not as a valid sound output option.

Any idea why this is occurring and how to fix it?

  • Are you trying to play music from your Mac or From your Windows VM?
    – MrDaniel
    Commented Apr 18, 2012 at 16:42
  • I'm trying to play music from the Mac.
    – Dillie-O
    Commented Apr 18, 2012 at 20:47
  • As an update to this issue, using the recommended steps below helped me diagnose the problem further to find a workable solution. I think it is going to vary based on your speakers and experience. In addition, I recently updated to VMWare Fusion 4 and the issue no longer presents itself.
    – Dillie-O
    Commented Jun 26, 2012 at 14:10

1 Answer 1


When a USB device is hot-plugged while VMware is running, I often see a dialog from the VM instance asking if the device should be attached to the VM or to the host OS. It's quite easy to miss this dialog if you have other applications running or if the VM is in a separate workspace. And until the dialog gets its answer, the device isn't attached to either OS.

If you're not seeing this dialog, it's also possible that VMware has already been configured with a default answer for the device in question. For example, it might automatically be attaching the device to the guest OS running in your VM. Note that this is not normally what you'd want with USB speakers, as VMware already emulates a virtual audio output device for use by guest OS's that funnels audio output through the host OS.

Have a look at your VM settings under "Virtual Machine > USB & Bluetooth Settings…" where you should see a dialog similar to the following:

USB & Bluetooth

I expect you should see an entry corresponding to your USB speakers. If so, you should be able to configure how they're handled when hot-plugged from there.

  • Sorry, I should have mentioned earlier that I DO see that dialog and I tell it to connect to the Mac when that happens, but still don't get the audio. That said, I think I might configure it to always go to the Mac, and hopefully resolve the issue permanently.
    – Dillie-O
    Commented Apr 18, 2012 at 20:50
  • Ah, that leads me to think that perhaps the Mac cannot instantiate a new audio output device while there is an active client of the audio subsystem running-- in this case VMware! If you don't need sound from Windows, you might try the experiment of disabling the sound card emulation for the VM. (See the Sound Card item under the VM settings panel.) Commented Apr 18, 2012 at 21:15
  • I shut down VMWare, restarted it, and set the speakers to always connect to the Mac. Still no luck.
    – Dillie-O
    Commented Apr 19, 2012 at 15:10
  • @Dillie, Seems like you have 2 issues. First, which you've dealt with, is ensuring that VMware doesn't claim the USB speakers. The other is that when you unplug the speakers, the MBP automatically changes the sound output to the internal speakers. I would not be surprised if you have to manually reselect them each time you plug them back in. Now that you've changed the settings in Fusion, the speakers should be showing up in the menu after you plug them back in.
    – Old Pro
    Commented May 3, 2012 at 6:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .